Jump to content
Corsair Community

Ax1500i came without cables?


Recommended Posts

Hello everyone,

I'm writing here as yesterday i bought an AX1500i PSU but to my surprise there are no cables in it!

Yes i'm referring to all the modular cables that are supposed to be attached to the psu and the power cord, they are missing from the package :S

The package was sealed so i'm sure the shop has not taken them out.

Has to anyone else happened something similar? How did you resolve?

:[pouts::evil:

Link to comment
Share on other sites

ive never heard of this before.,,since just purchased ,,going thru the vendor where bought for a replacement is your fastest route,or you can submit a rma and have corsair take care of it

going the latter route,,please have your proof of purchase available...

Link to comment
Share on other sites

ive never heard of this before.,,since just purchased ,,going thru the vendor where bought for a replacement is your fastest route,or you can submit a rma and have corsair take care of it

going the latter route,,please have your proof of purchase available...

I'm worried that the shop might think i stole the cables, even if there's no really a reason to do something like that. I still have the proof of purchase ofcourse, do you think if i submit an rma corsair will take care of it?

I was planning to build the machine this week but i guess it wont be possible :mad:

Link to comment
Share on other sites

you can submit a rma and in the comments box explain the issue and they will let you know what they can do,.it also would seem [to me] that there would be no reason to need an extra set of cables as it wouldn't serve much of a purchase being the 1500I comes with a full set which imop is reason enough for the vendor to not doubt you.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...