Jump to content
Corsair Community

Discuss Link Release Candidate v2.7.5339 here


Technobeard

Recommended Posts

1. v2.7.5339

2. Windows 8.1 64bit

3. H80i fans and pump not displaying info in Corsair Link.

4. I noticed my PC fans were a bit louder than usual and after trying to switch to quiet mode in the task bar and not hearing any difference I decided to look at opening the Corsair Link window to see what was happening.

 

I could then see why my fans were not slowing down after changing the preset mode of the Corsair Link in the task bar. Nothing from the H80i was showing up in the window of the Corsair Link and the data was missing from the talk bar under fan and pump info as well.

 

I tried a few things that didn't help. I quit Corsair Link and ended the process in Task manager and restarted it and it was still not working as seen in the picture.

 

I then restarted my PC thinking that that would fix it but after rebooting it was still the same.

 

The only thing that finally got the H80i dials to start working again was to go the the options in Corsair Link then the general tab and then select reset to default. Only after resetting to default did the H80i dials and stats start working I then just re applied my profile to get it back to the way I had it before.

 

Just to be safe I created a new profile and deleted the old in case that profile was corrupted.

 

Hope this helps someone else in this predicament.

 

 

After upgrading 2.5 to this 2.7 RC on an X79 Dark All 5 of my case fans went missing, thinking it was a huge Bug yest to be squashed I did do a reset to defaults as you suggested, closed Link and Rebooted, low and behold They are back.

 

You wouldn't think a reset to defaults would redetect devices even after deleting the entire profile folder, but it did for me.

 

That should be listed in the sticky on the step after you reinstall the 2.7 RC.

Link to comment
Share on other sites

  • Replies 238
  • Created
  • Last Reply

I have noticed when I run SIV (http://rh-software.com/) and Corsair Link at the same time the Corsair Link hardware values reported by both programs are erratic however the Motherboard and GPU information is all correct. After some checking I found Corsair Link correctly uses the Access_SMBUS.HTP.Method and Access_ISABUS.HTP.Method mutexes to interlock access to the SMBus and ISA Bus, but there is no mutex to interlock access to the Corsair Link hardware. Both SIV and CL++ now use Access_CorsairLink (http://forum.corsair.com/forums/showthread.php?p=728998#post728998) for interlocking. Please can Corsair Link be corrected to also use Access_CorsairLink?

I tried raising this as a support ticket and was less than happy with the reply of:

Created By: Justin G. (9/22/2014 1:43 PM)

Thank you for your feedback Ray. I regret to tell you that we cannot support your request at this time.

Link to comment
Share on other sites

So...again a new version and again nothing works. Why does Corsair produce such excellent hardware, but fails so dramatically when moving into the software business as with Link?

 

This is what I get when opening Link:

 

It's a fresh clean installation of Windows. Any ideas guys?

 

  • ASUS Rampage IV Extreme Black Edition
  • Intel i7 4930K
  • G Skill F3-17000CL9Q2-32GBZH
  • ASUS GTX 780ti SLI
  • 2x Samsung 840 Pro 256GB raid0
  • Corsair AX1200i
  • Windows 8.1 Pro 64-bit

Link to comment
Share on other sites

What have you tried, to solve the problem?

 

Good question. Basically everything:

 

Removed USB connected devices

Fresh installation of everything

Fresh installation of only Windows and Link

Not connecting PSU to H100i

Connecting PSU to H100i

 

Any more suggestions and I'm all for it :)

Link to comment
Share on other sites

1. v. 2.7.5339,

2. Windows 8.1 Pro

3. As of 09/23/2014: No Thermister Temps and No Memory Temps from AirFlow Pro.

4. a) System display is reset to zero temps and fan speeds upon PC shutdown and boot, if it even displays them at all.

4. b) AX860i Temp & Fan both display on System Tab, but only Fan is displayed on the Power tab.

4. c) Does not handle or recognize 2 HDDs as different when they are the exact same make and model number (not in RAID), and only displays 1 of them.

Link to comment
Share on other sites

Hi guys,

 

I had a break-through. I installed Corsair-Link-Installer-RC-v2_5_5145 and it works! Just like I thought, it's a software issue. Corsair really have no clue what so ever howto code... To bad because their products are actually really great.

 

 

Thanks for your efforts tho.

Much appreciated!

 

 

BR

Andreas

 

 

PS It's an AX1200i PSU

Link to comment
Share on other sites

1. Windows 8.1 Pro 64-bit with Pro Pack

2. Ver. 2.7.5339

3. I saved my profile and shutdown my PC overnight (PSU still On), because I got a new UPS. Upon boot up this morning, as usual, No H100i, No H100i fans, No Case Fans, and of course, no Memory temps from the AF Pro.

4 After disconnecting the Mini completely and running fans off the MB, then shutting down and put fans back on the Mini, it sort of worked until the next shut down.

5 After 2nd mandatory shut down, I now have No Case fans, No H100i icons, see 3rd attachment

WHEN it works it works, when it does not work, it is a frustrating, depressing, worthless venture.

 

The USB unplug procedure does not fix, so for the now 95th time (I keep track) I had to uninstall the Link software and re-install it, (yes I deleted the profile),putting me back at square one, having wasted now way over 104 hours and I am still at square 1.

 

What has never worked:

1) No memory Temps from the AF Pro plugged into the Mini.

2) Matching part/model number HDD's (2), Link displays only one of them.

 

Question: What is the definition of the opposite of "Robust"; the answer, "Link Software".

PLEASE put more $ and time on fixing this software !

1593598407_NN-Beforeshutdownandreboot-LinkVersion2-7-5339-SystemusingW8.1andCommanderMINI.thumb.png.fc9b441cfa2dd679ccd5275b2c33659b.png

2050992101_NN-Aftershutdownandboot-LinkVersion2-7-5339-SystemusingW8.1andCommanderMINI.thumb.png.9529cbba2949c37a87f60ff40fc73ba9.png

1338343912_NN-After2ndshutdownanduninstall-reinstalltwice-Profilesdeleted-USBproceduresdone-Link.thumb.png.4bd3273546beebbb29e9a0b1479609b9.png

Link to comment
Share on other sites

The real question is, why is this an issue at all? Especially after this amount of time.

 

Speed you think to fast for them :D:

 

I have found a solution that works for me. .... then went into REGEDIT and used "Find" and deleted every instance of "Corsair". I then reloaded 2.6.5214. I no longer get double the icons with "0" value icons. The program is still just as buggy as it used to be, but at least the program WORKS. Maybe the next update will fix the fix! Call me an optimist.

 

Well that is what we are required to do in 2014 :D:

 

Having rolled back to v2.4.5110 I notice a problem with the 1.0.7 firmware: The LED colours can be set correctly but when the PC resumes from standby or restarts the set colour turns whitish, i.e. deep blue --> pale blue, and has to be manually set again to the correct colour. Rolling back to the 1.0.5 firmware resolves this.

 

I reported this a while ago, please see OP r/w to firmware and 1.07. 1.05 is golden buy does not run there newer software.... search and you will find.

 

Based on the last few pages it appears they have got all the bugs out and all runs smooth now. :bigeyes:

 

I have no need for this since I run quite and ,>255,0,0 and I set it with 1.05 and 5110 uninstalled it and that's it. Glad I am not dependent on it would be sad for me.

 

Regards

Link to comment
Share on other sites

1.05 is golden buy does not run there newer software.... search and you will find.

 

That's what I thought, but I appear to running Link 2.7.5339 with 1.0.5 firmware in my H80i and it is mostly ok (except the issues I have posted).

 

I can't quite recall how I ended up with this combo but it was something simple like -

 

1. Install Link 2.7.5339

2. Let Link update the firmware to 1.0.7

3. See that 1.0.7 has undesirable issues and update the H80i with the 1.0.5 file

121866933_Link2.7.5339About.thumb.JPG.4b4d4c489bb4b18796d903e2d0c19198.JPG

1359454168_Link2.7.5339Devices.thumb.JPG.2bf3cd83c2c154aba05cd35d09859c2d.JPG

Link to comment
Share on other sites

Windows 8.1 64-bit here.

 

Corsair Link works in its latest version (profile save, custom curve works, etc) BUT eventually it stops loading the icon at startup. When you clear icon cache, it is restored for one restart, I don't know why (but the app is loaded in memory), then dissapears again. AND you have to apply USB energy saving fix (you have to disable it) for the pump and fan info to be working.

 

See specs in my profile. Fix this ASAP plz. This is driving me insane.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...