Jump to content
Corsair Community


Recommended Posts

Corsair Link 2.6.5214 under Windows 7 x64 Ultimate, not running Asus Suite AI... H100i, Corsair Link Commander, Corsair Link Lighting Node.


Firmware Updater tried to update link lighting node, apparently with H80 firmware from what flashed on screen, now lighting node doesn't work at all, automatic recovery fails with "too many retries" and forcing update to lighting node firmware included with Link software fails as well, with no other error information. It would be nice if future versions of the software would report where the failure occurred (I/O, memory, wrong device identifier, etc.).


The Link gear has been a non-stop hassle since I bought it, but having programmable lighting in my system was nice when it worked. Additionally, Corsair Link is insisting I update my already up to date H100i, like I'm going to trust it to do that... :eek: Maybe a USB-RS232 converter, an Atmel uC with PWM, and a little NVRAM would have been a better way to go for lighting. It'd be able to recall its settings between boots at least, and you could always manually reflash it in a pinch manually.


Is there another way to reflash the firmware on this thing or is it just toxic fodder for the landfill now? Any utility independent of the link software? A third-party hack even? If I need to RMA, is there some warranty period even though it seems your software was the cause? Can I keep the LED strips and RMA the node itself since you don't sell the strips and they're fine?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...