Jump to content
Corsair Community

Vengeance 1500 v2 causing BSoDs


Recommended Posts

So i've narrowed down my issue to the headset.


Basically what's been happening is that Windows 8.1 will go into a stall upon shutting down... (This is after signing out, and all programs are closed)

After about 10 minutes of "shutting down" I get a BSoD with the error "DRIVER_POWER_STATE_FAILURE"


I had no idea what was going on and was scratching my head until I noticed another issue.

Every morning when I had been signing on my computer to get started for work, I noticed that when I plugged my Vengeance 1500 in, it would get power, but would not turn on. (Lights on the volume control would be pink signalling power, not blue signalling that it was fully functioning). It would require me to reboot my computer and since I wasn't able to shutdown fully, I had to hard-reset the machine (Hold the power button).


Today I figured i would shut the machine down (hard) then reboot it and shut it off without EVER plugging in the headset.... Lo and behold it worked. I have no idea what's happening. Best thing I can see is that the system does not recognize when I "pull the plug" on the headset to take it out at the end of the day.


Does anyone here have any idea? I can't exactly "Eject" the headset.

Could it be an issue with the headset hardware?



Edit: i have noticed that when I have the headset only plugged in for a few minutes, the system will recognize when I pull the plug.

Link to comment
Share on other sites

Have you tried updating the BIOS, chipset drivers and tried a different headset driver version?


All my drivers are currently updated to the latest versions. I had to do a massive update on everything for my new job. I haven't used a different driver version because this driver specifically claims that it fixes a windows 8.1 compatibility issue. Which older driver version would you recommend?

Link to comment
Share on other sites

  • 1 month later...
Try BETA 2.0.25 and see if that helps.



Have you also tried turning off any power savings features in Windows and the BIOS (If there is any)?


i know it's extremely late to reply to this: But i recently had to enable power saving featurs in windows to try and save my room from being rediculously hot.

Also noticed this morning when i logged into work, that my computer had startup errors, so i don't know if it's associated with this or not.


Was going to try that beta link, but link has already been removed.

Link to comment
Share on other sites

I work from home on my own personal computer so asking my work IT department wont help.


Not to mention my computer now refuses to boot up if the headset is plugged in.

And it's only the headset... Any other USB device is fine, but if the headset's in, it will sit there and constantly restart the startup process once it hits the windows 8.1 logo

Link to comment
Share on other sites

I have a similar issue with some USB devices on my EVGA X79 Deluxe. If I don't have them plugged in I will get <15 second boot time. With some devices plugged in it can be >2.5 minutes. Some motherboards just don't play nice with certain devices. It's not really the fault of either manufacturer, it's just how things work when there are so many different devices. (Same thing happened with my sound card on an earlier BIOS version as well)


I would check and see if there is an updated BIOS for your motherboard and also contact them about it to see what they have to say.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...