Jump to content
Corsair Community

Corsair Force3 60GB problem


Recommended Posts



The Force3 60GB (firmware 5.05 latest) is my Win7 boot drive in laptop. Yesterday I got intensive BSOD, so I decided to restore from TI image backup. The image backup was verified & restored successfully without error, but the SSD failed to boot, giving me a black screen with blinking cursor on the top left corner. I know the image is fine because I've used it several times.


I decided to secure erase the drive in my desktop comp. The desktop has Force3 120GB (Firmware 5.07) as the boot drive with Intel SSD 320 80GB + 3 HDD. I tried to secure wipe the 60GB SSD with Corsair Tool Box 1.1, but it gave me BSOD as soon as I started.


BSOD message : "A problem has been detected...bla bla bla. MULTIPLE_IRP_COMPLETE_REQUESTS. STOP: 0x00000044".


Tried to secure erase with Parted Magic, and it went through (after lots of SSD being Frozen message).

I booted to Windows (desktop comp). When I tried to initialize the disk with Disk Management, it gave me BSOD again : "MULTIPLE_IRP_COMPLETE_REQUESTS. STOP: 0x00000044".


Booted into Parted Magic, initialized the drive & partitioned the drive. No problem.

Booted back to Windows / Disk Management, I could see the new created partition. Strangely, when I tried to delete the partition, the partition remained intact as if nothing happened. Win7 or Disk Management didn't give me any error. Rescan drives in Disk Mgt & reboot, the deleted partition is still there !!!. Using Diskpart to delete partition, same problem. No error. Diskpart said "Partition deleted", but it is still there in Disk Management & even after reboot.


Another secure-erasing with PMagic --> initiliaze the disk by Win7 Disk Management --> BSOD.

Going back to PMagic to initialize the drive, no problem. Booted back to Win7 Disk management & tried to create Simple Volume --> when started to format --> same BSOD.


Checking Win7 integrity--> no problem.

I tried my brother's laptop through ESATA connection & retried to create partition in Disk Management ---> BSOD.

Going back to PMagic & create partition.

Going back to my bro's laptop, and tried to delete partition (experiment), SAME PROBLEM ---> Dsk Mgt gave me no error, but the partition is still there !!! Tried Diskpart --> same problem.

Going back to PMagic to delete partition --> successful.

Going back to bro's laptop & tried to create partition from Un-allocated space --> NO partition created, but Dsk Mgt gave me no error message.

Trying an empty HDD , and the same computers do not have problem creating & deleting partition of other disk (I've tried with HDD).


Looking like a totally dead SSD, doesn't it ?

Not yet.


Going back to PMagic & created partition there.

This time I retried another TI restore to the created partition & successful. It finally booted.

Smart Data is good. Everything seems normal.


What is going on with this SSD ???

Is it dying on me ? Why suddenlly Win7 Disk Mgt suddenly can not do anything to it anymore ??? Not even Corsair's Own Secure Wipe. Only Pmagic can.


My drive is exactly 3 years old next week.

If this drive has problem, I definitely has to RMA it asap (like this very week !!!).



Additional note:

SSD is connected to the primary Intel controller of Biostar Z68 board (AHCI)

Laptop is HM55 chipset (prinary intel controller) (AHCI)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...