Jump to content
Corsair Community

PC doesn't start up with new Corsair AX860!


Recommended Posts

Hello folks, recently I bought a new PSU for my rig, I was using an AX850 and now AX860. The problem is that I can't get the PC to start up, the motherboard green LED shine but when I press the power button in my 350D nothing happens!


I took some pictures so you can help me see if I'm missing a cable to connect or something else.


Here you can see 24pin motherboard, 8pin CPU, and all SATAs (SSD and HD) connected (sorry for the dirt, I was waiting the new PSU to clean the case and stuff):




And here is the AC Power cable connected and also the ON interruptor on the PSU (''I'' position):




And finally the cables connected on the PSU itself, everything connected where it is suppose to be connected:




I really don't know what I'm missing, the PSU isn't faulty I can confirm for sure, because this is my second try to make it start up without sucessful, the first I received the PSU I thought it was faulty, so I returned to the store where I bought from and they tested, recorded a video and everything working without problems, so they returned the PSU to me and again I'm with this same problem.


If anyone can help I would be glad, sorry for my bad english.



Link to comment
Share on other sites

So your PC doesn't do anything when you press the power button ?

It doesn't look like there'd be any missing cables.


Yes, nothing happens when I press the power button. I tried this PSU in a different PC and the PC started without problems. I don't know what is happening, someone told to clear de CMOS but I don't think that is the problem, since I only changed the power supply.

Link to comment
Share on other sites

Did the old PSU stop working?

If not, and I know its a pain in the backside, try the old PSU.

If it still doesn't fire up then one of two things has probably happened:

1) You have pulled some connections off as previously posted by ppl

2) You've fried your MB (Static/Unlucky)


Hope you get it sorted!

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

So the 850 worked and the 860 does not, but the 860 powers up a different board? Hmm....


Only thing I can think of is the PG Signal timing must be different. If the MSI board can power up with a different PSU, any chance you can flash the BIOS?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...