Jump to content
Corsair Community

Vengeance 1500.. I Have tried Everything! Help Needed


Recommended Posts

Hey everyone,


so on friday nights I catch up with friends and play BF4 but this friday past my corsair vengeance headset stopped working. I spent hours trying to figure out with with no luck at all, I browsed this forum over and over trying different things and still no luck.


The headset lights up showing it has power and my computer initially see's a usb device has been plugged in but than says device unknown could not install driver. When I go to the properties of the device it shows code 43.



I have removed software and re-installed

Installed older software

Tried every usb port on my computer

Uninstalled drivers through the device and re-installed


Last night I reformatted the computer wiping it completely out and re-installing all software... Well no luck still! I can not get the computer to see these headphones and work.


So I thought for sure that the headphones have bit the bullet and are no good but first decided to plug them into my macbook pro. (Which there's no compatible software for os-x) but no problem they showed up Corsair Vengeance 1500 and I could hear out of them.


What am I doing wrong?



Zalman MS800 Plus

Asus M5A97 LE R2.0 Mobo

Samsung 840Evo 250 ssd

24gb Gaming ram

Sapphire R9 290X

Corsair TX650 psu

AMD FX8320 cpu

Hyper Cooler


Now I do have speakers hooked up to my computer right now and sound will come out of them.. I wanted to make sure that the sound card still worked. Is it possible that the sound card can still be faulty?



Thank you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...