Jump to content
Corsair Community

M95 won't remain in software mode


Recommended Posts

I can't be the only one having so many problems with the M95! I just bought it to replace my failing M90 (currently on its way to Corsair for RMA).


I would like to use hardware playback mode, but there is some kind of malfunction where lifting off of one of the thumb buttons (one set to play a macro) causes the mouse to send button-up for both main mouse buttons even though I am still pressing them. It renders the mouse unsuitable for its intended purpose as a MMO mouse in the way I play (pressing the two buttons to move and using the thumb buttons to activate various combat abilities). My M90 didn't do this at all, and the M95 doesn't do it in software playback mode.


Ok, so I can use software playback. Works fine until I put the computer into standby mode and wake it up-- then it reverts to hardware playback mode, even though the checkbox in the M95 software for hardware playback is not checked. If I check and then uncheck the box, it properly goes into software mode, until the next standby.


I tried uninstalling and reinstalling the mouse program and reflashing it with the latest firmware. Neither worked.


Either the mouse is defective, my puter is playing a joke on me, or Corsair has released a product that is not ready for prime time.


EDIT: Tried it on my 7 year old Win XP laptop too (main PC is a desktop i5-2500k with Win7 x64). Same issue.


Does anyone reading this have either of these issues?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...