Jump to content
Corsair Community

Corsair HS40 installs but does not work/appear


Recommended Posts

There is nothing wrong with the headset; I've tested it on another computer. I've also tried a different USB headset and can't get it to work either. The problem must lie with the USB ports on the comp and I can't figure out how to fix it.


When I plug it in windows appears to install the drivers successfully. I go to the device manager and verify that CorsairHS40 is present and with no errors. I go to sound in my control panel and see the CorsairHS40 icon. When I click on it it says "please connect the headset", even though it is already connected. When I go to recording/playback devices, it is nowhere to be seen (disabled and disconnected devices are set to displayed).


I've tried uninstalling/reinstalling numerous times. I've tried updating chipset+USB drivers from gigabyte. My motherboard has USB2 and USB3 ports... I've tried all of them. Other USB devices I have plugged in are mouse and keyboard.


So I'm left being able to use only headsets with 3.5mm connections on this computer. Highly annoying! I'll have to return the headphones unless you can help me fix.


Many thanks

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...