Jump to content
Corsair Community

Corsair Link - H100i and AX760i problem


Recommended Posts

Just had a new rig built using Corsair's H100i cooler and AX760i power supply but http://www.cool-smileys.com/images/Crying-Smiley.jpg the H100i did not show up in Corsair Link whilst the AX760i did. On investigation the H100i pump had not been connected to a USB header whilst the AX760i was connected via the included Link dongle.


Searched the web and got the Corsair video of how to set these up correctly i.e.

1. Bring the cable from the comm port on the AX760i up to the port on the side of the H100i pump.

2. Connect the included USB cable from the H100i pump to a USB header.

3. Remove the Link dongle.


Did all of this but now the H100i shows in Corsair Link but the AX760i doesn't. I've spent 24 hours of the web and forum. As the result of what I've read I've checked all connections, un-installed Link, including the profile folder, and disconnected the USB connection and then re-booted so that Windows would boot without finding the parts. Power off, reconnect USB and reboot and new install of Link V2 6.5214 but still the same, namely H100i appears in Link but AX760i doesn't. Repeated all the steps above but this time reconnected to a different USB header but with the same result.


Any help would be much appreciated to make me :biggrin:

Link to comment
Share on other sites

PSU does not show in Link devices tab.


Have checked the seating of the cable on the PSU comm port and the H100i pump port but no difference.


My next steps are:

1. Remove this connecting cable and check the continuity of the individual wires to make sure there are no broken connections.

2. Re-route this cable from the PSU to a USB header using the Link dongle (as it was first installed) and see if the gets it to appear in Link.

Link to comment
Share on other sites



Reverted to V2 5 5145 as per the instructions.

AX760i fan speed and temp are now reported in Link in addition to H100i.




1. My graphics card fan speed is missing but it's temp is reported

2. My second hard drive is reported but it's temp is now missing


These reported correctly using Link V2 6 5214


Clearly this is a software issue and not, as I had suspected, a bad connection or faulty cable from the PSU to the H100i pump

Link to comment
Share on other sites

Now that it's established not to be a cable/connection problem I'll go back to V2 6.5214 and connect the PSU via the Link dongle to a USB header as this configuration reported the PSU in Link when the rig was first built. The reason the H100i wasn't picked up initially was that, by mistake, it wasn't connected to a USB header but when I did connect it it was also recognised by Link using V2 6.5214.


If this works and I get my other items back, GPU fan and Hard Drive temp which were lost moving back to V2 5.5145 then I will report this in the Corsair Link thread you directed me to. Thanks again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...