Jump to content
Corsair Community

Windows 8.1 lighting/cooling do not work at all


Recommended Posts

I have not messed with this kit in about a year. I have the Corsair light/cooling kit. I have a light node and a fan node. I recently installed Windows 8.1 and downloaded the Corsair link software. My lights are on and my fans are spinning. I can click the button on the light node to change the color of the light.


I cannot see anywhere to adjust fan speeds.


I cannot see anywhere to change lights.


What do I have to do?

Link to comment
Share on other sites

I don't think it was detected by the "newer" software.


I uninstalled Corsair link from the control panel.


downloaded the older version 1.2.7 beta.


tried to update with the 2.06 FW and the program locked up. I waited 20 min and nothing.


restarted computer..now I need administrator access to run Corsair link.


I tried to right click and "run as admin" is not available. It is available with other programs.


Thank you for your help.

Link to comment
Share on other sites

so I found another place to "run as admin" under the compatibility tab. When i try to update the FW, it says that Corsair Link needs to be restarted.


Either, I click "ok" and the program locks up.




I hit cancel and restart Corsair link and the same question appears again



Link to comment
Share on other sites

If you have updated the Commander unit to 2.0.6, uninstall beta 1.2.7 and install 2.4.5110, use that software firmware updater to update the nodes to theses versions for the newer software.


Firmware auto detection at first startup. User selectable option to update or not. Needs minimum versions listed below for detection inside software. Firmware files are part of the install package. No separate download needed.

CoolingFW_1.2.8 (Cooling Node)

HydroFW_1.2.8 (H80/H100)

LightingFW_1.1.9 (Lighting Node)

USBFW_2.0.6 (Commander unit)

H80i_v1.0.7 (H80i)

H100i_v1.0.7 (H100i)

Link to comment
Share on other sites

It is not listed under Devices and Printers. I have tried both USB headers on my mobo. I know these work as they are used for my USB ports on my case. This unit has worked before. However, I was using a ASUS Rampage 3 X58 board. Now I am using a EVGA X58 FTW3 board.
Link to comment
Share on other sites

Open Device Manager are there any unknown devices listed?


Here are the L.E.D. status

Green on and off (about twice per second) means that Stingray is attempting to connect to Windows. It will flash red every ~10 seconds if it cannot and will keep trying.


Solid green and flickering orange is used to show activity; since SierraSerivce is always running, the USB Commander should always be flickering.


Red on and off (about twice per second) indicates some hardware failure or that the unit is in boot-loader mode.


Any ideas which one it may be? I'm guessing it will be the first one.

Link to comment
Share on other sites

Hardware Ids for the Commander unit are



It won't show as "Commander Unit" instead it will show as USB Input device or HID compliant...


If you cannot find it in Device Manager, can you try it on the previous motherboard or a different computer?

Link to comment
Share on other sites

  • 4 weeks later...

hello....sorry its been awhile...but i found a another computer to test it on. When I plug it into the other computer, it makes a found hardware noise over and over again. It does the same thing in my old computer. In my old computer, I had disabled a USB root hub for the found hardware noise over and over again before. At the time, I was not thinking about the Corsair link as the cause.


So what should I do now?

Link to comment
Share on other sites

I updated windows and installed the latest link software and it works!!! no regedit for me.

Maybe a windows update fixed the USB sound isssue????


Everything worked except I cannot control my cooling node/fans. It sees the cooling node under options/devices tab and updated it, but on the left side of the system tab it does not show up, so I cannot configure it. Also, Link cannot see both of my EVGA 670's just the top one.

Link to comment
Share on other sites

uninstalled...restarted...reinstalled....restarted....same thing. It sees the cooling node in devices, but a icon does not show up under the configuration.


.net 4.5.1 is installed with Windows 8.1. updates take care of it from there. Is that good enough..or do I need to get a different version??

Link to comment
Share on other sites

I moved it from #8 to #1 slot on the link commander and it picked the fans up without any problems!!!


cha ching!!!!!!



Thank you again :)



I am almost there....the last thing that does not read it my 2nd GPU. I have EVGA GTX 670 4GB in sli. It only reads one, the top one.


this is not that big of a deal..but I have dreamed of a day when I could have all my temps monitored by one program and we are almost there!!!



Thank you again for your help and continued support.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...