Jump to content
Corsair Community

M45 Problem


Recommended Posts



I recently ordered the raptor m45 gaming mouse and got it today, i plugged it in to my computer and everything worked very well.


I went to the corsair page to download the software and firmware. I installed the software and it all worked nicely, but then i installed the firmware i got a message to restart my pc. when i restarted the pc the lights on the mouse started to blink and now it won't work, the only thing that works on the mouse is the right and left button+ the scroll wheel.

when i open the firmware it says:

"Cannot open USB device, please plug the device into a USB port or reinstall driver!"


i've tried all the different USB ports on my pc and even on other computers, still it doesn't work...


OS: Windows 7




Please help!

Link to comment
Share on other sites

Thank you so much!


had to go through the instructions twice before it worked.

after the second time the lights on the mouse was turned off, but when i changed USB port the mouse worked perfectly fine! :biggrin:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...