Jump to content
Corsair Community

M60 Tracking / Firmware issue


Recommended Posts

I'm having a very strange and very frustrating issue with my M60 mouse. On my laptop (2012 Alienware 14x), the mouse functions normally, but tracking seems broken. In the Corsair M60 gaming mouse configuration application, it will detect surface quality, so the laser clearly works, but the pointer doesn't move, no matter how much fiddling I do with the settings.

After scouring these forums, I tried using the M60 Firmware Update Program v1.12 to reflash the firmware. This works for the space of about twelve seconds. Once the firmware update program displays 'erasing flash memory' the device will track perfectly! When the firmware update completes, however, the tracking reverts to its unresponsive state.

I have tried terminating the firmware update process using task manager to try and keep the tracking working, but doing this prevents changing any settings using the config. I would be happy with the workaround I've stumbled across, but the resulting DPI setting is unweildly.

Is there any way to fix this issue properly?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...