Jump to content
Corsair Community

link dosent show in desktop


Recommended Posts

I have exactly the same problem.


The icon just doesn't show up in the systray.


But it is actually running, but the fan speeds are not adjusted according to the profile until i start it manually. Then it says "Corsair Link is already running" in a ballon popup and then the icon shows up and after that the fan gets adjusted immediately.

If i check the tasks scheduler, ist shows the app as running. (And it is running.)

I also tried adding the link from my desktop to "shell:startup", but that does exactly nothing.


Also if i check "Startup Minimized" in the Options, it does nothing. I keeps reverting to an unchecked box.

The first time i set this option it corrupted my profile, causing the app to crash entirely on launch. I deleted the Profile and created a new one, this worked, but now i cant set the option at all.


All i want is, that it starts up automatically and minimized.


Oh and before i Forget: I have Win 8.1 and the latest .net and Corsair Link installed. (I actually just upgraded to the latest version in the hopes this little error would be fixed, but its the same with the previous version.)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...