Jump to content
Corsair Community

New Error showing up


Recommended Posts

Aside from the casual error of whatever folder not being found i now have a new error occuring when ever i use the app;


Internal Server Error


i can't do anything at all and i've had the drive on and off the past few days and haven't gotten rid of this error. As of right now the functionality of the drive is that of one 1/3 of the price.

Link to comment
Share on other sites

This reflects an error in the library database. I suggest deleting the hidden folder ".vapoc" and power-cycling the drive, which will rebuild the database.


If it persists, it may mean it is having trouble with one or more of your media files. Try moving files (temporarily) to a different drive, then move them back in stages, checking each stage, to see what is causing the issue. And if this uncovers an issue, please let me know the details (so that we can replicate and fix). We have done a lot of testing, but can't possibly duplicate all the types of files that people have in their libraries.



Link to comment
Share on other sites

Reinstalling the firmware made this go away, but i still have this reoccuring error on and off;


DirectoryIterator::_Construct(/shares/internal/disk0): failed to open dir: No such file or directory
Link to comment
Share on other sites

Hmm ... never seen that one before. When does it occur?


Usually i get it after i unplug the usb3 cable or turn it on and off rapidly. I've been getting it ever since the 2.0 update and turning off the drive for 5-15 minutes then turning it back on seems to sort out the problem.

Link to comment
Share on other sites

  • 2 weeks later...
This reflects an error in the library database. I suggest deleting the hidden folder ".vapoc" and power-cycling the drive, which will rebuild the database.


If it persists, it may mean it is having trouble with one or more of your media files. Try moving files (temporarily) to a different drive, then move them back in stages, checking each stage, to see what is causing the issue. And if this uncovers an issue, please let me know the details (so that we can replicate and fix). We have done a lot of testing, but can't possibly duplicate all the types of files that people have in their libraries.




I have run into the same problem. I've been using my drive of late just as a simple external USB storage device. Today, I went to use it as a wireless server and I'm getting the internal server error. This is via both the web interface and the latest Android client. The device itself is still running the 2.0.17 firmware.


I tried deleting the .vapoc directory, no luck.

I bit, by bit, deleted everything off the drive so there was nothing left on the drive (apart from the usual OSX cruft). Still no luck.

At that point I thought I may as well try updating the firmware as I've got nothing to loose.

I plugged it back in as a USB device, copied over the 2.1.2 pkg, unplugged and power cycled.

That made the device worse. Whereas before I could connect but I'd get the "Internal server error" message. Now the app could connect to the server neither could the web browser. However SMB still worked. Similarly, I noticed that the network passthrough I'd previously configured is still working.


What's the next step?



Link to comment
Share on other sites

It sounds like there are two possible sources of problems:

1. The firmware is not correctly installed. If you cannot connect to it via app or web browser, this is likely. It could be that some elements of the server are starting (SAMBA), but at some point it fails.


2. You might need to reformat the drive. If you have moved your content to another drive, this might not be as painful as it otherwise could be.

Link to comment
Share on other sites

Thanks for the response, but I suspect I mightn't have described things very well.


The firmware was working. I have used the drive successfully as a wireless NAS. Over the last few weeks I was using it as a "dumb" external USB drive without any problems. I have now attempted to again use it as a wireless NAS and whilst I can get to the web interface, when I try to browse to files, I get the "Internal server error" message come up.


I did attempt to upgrade the firmware. But I only did this as an attempt to see if I could resolve the "Internal server error". However, as I noted above, when I had the package on the drive, the Android app couldn't even connect to it in wireless NAS mode. So the firmware upgrade was never commenced. [Aside: when I first bought the drive in mid June, I did successfully upgrade the drive to the 2.0.17 firmware, it operated correctly after that].


So regarding point 1: I can access it via the app and web browser and SAMBA. The only time it didn't work, is when I put the 2.1.2 firmware ".pkg" file onto the root directory of the filesystem as an attempt to perform a firmware upgrade. If I had that file on the drive I couldn't access the drive. If I plugged the drive back in via USB and removed the file, when I connected to it again via wireless; app, web and samba access all operated - but web and app gave the internal server error message.


Following on from your point 2. Whilst I haven't reformatted, I've run the OSX Disk utility on the drive and performed both a verify (which didn't report any problems), and a repair (just for good measure). They both reported the drive was in good health.


Running in wireless NAS mode, I am able to see the drive via OSX's SAMBA interface, and I am able to create a folder on the drive. I have then rebooted the drive to external USB mode and plugged it into my mac. I am able to see the folder I created. So it would appear in both modes, the filesystem is usable.


My impression is that the firmware on the drive is functioning correctly. The filesystem on the drive has no problems. My guess is that there is a config file in the firmware (i.e. not in any of the files in the ".vapoc" folder), that is confused/corrupted, that needs to be rebuilt. But it's not documented how do go about triggering such a rebuild.


Is it possible the "debugging connection" in the Android app could be used to get in and cleanup the firmware configuration file? What/how are the "Host" and "Password" fields on that screen used?


One final comment (which may well be completely unrelated to do with the problem). I've been away travelling and used the drive to backup files from my video and still camera. At the end of one day, when completely exhausted, I had a brain failure and deleted the contents of one of my SD cards. As part of my attempt to recover the files I deleted, I did a dd of the 32Gb SD card and had the 32Gb SD card image stored on the drive. Initially I thought this "non-media" 32Gb file may have been what caused the "internal server error". So it was the first file I deleted from the drive. It didn't fix the problem. Given that the (big) firmware ".pkg" file also caused weird things to happen, I'm wondering if the problem could be caused by storing large non-media files on the drive.

Link to comment
Share on other sites

Storing big non-media files on the drive should not cause the "internal server error" message.


As I understand it, things are stable for you right now running 2.0.17.


You should try downloading and installing the new firmware through the app (not by copying the file using USB) to see if that makes any difference. It should.

Link to comment
Share on other sites

It's stable - because it's unusable ;-). If I connect over wifi to the VA with my phone, and then point my phone's web browser at, I get the left hand column with: Videos, Music, Photos, Documents, <gap>, Folders, Recent, <gap>, Settings, Active transfers, Now playing. If I touch on "Settings", nothing comes up. Touching "folders" gives me the "Internal server error".

If I start the app, I immediately get the "Internal Server error" popup message. The left hand list only has: Downloads, <gap>, Settings, Now playing. If I touch on "Downloads" I see the 4 Videos, Music, Photos, Documents sub folders. If I select Settings, I get:


Network Status: Disconnected


App version: 2.1.0


Debugging connections: Change

App revision: e128be4

There's nothing there that give me to a function to upgrade the firmware.

Link to comment
Share on other sites

Ok, I misunderstood your current situation. You definitely need to reinstall the v2.0.17 firmware. I strongly suggest reformatting of the drive, too.


You can continue to run the newer version of the app - other than a dialog when the app starts it will work fine.

Link to comment
Share on other sites

  • 4 weeks later...

Hi Bill,

(sorry this is so long)


I tried a few things before responding:

1. I've reformatted the drive.

Even trying both HFS and VFAT.It made no difference.

2. I've tried pressing the reset button thinking it may reset all settings.

That wasn't a great idea![1]. It didn't fix things.

3. On my Linux machine, mounted the UBIFS image from the downloaded and looked at the firmware filesystem.

It's frustrating that password details are not provided for access via the ssh daemon that's running on the device.Working as a Linux admin, I could probably fix what's wrong (or at least provide a more detailed problem description), if I had command line access to my device.


So where I'm at is I have no way of reinstalling the firmware. The app just returns an internal server error when I select setup. Similarly, with the web interface, the setup option displays a blank page (I can't remember if it also popped up the "internal server error" message when selected).


Currently, I can only use it as a "dumb" external drive. I can browse the drive via samba. I can see the files via the web/app interface, but attempting to get into setup to change any settings (or initiate a firmware upgrade), results in the "Internal Server Error" popup message. Finally, it will do internet passthrough - which since pressing the reset button is not an option[1].


Given those constraints, is there any way of forcing a firmware reinstall and/or clearing all the settings stored in the firmware back to factory defaults?


[1] The problem with the reset button, is that it only clears the wifi password, not all the settings. I live in an apartment complex and can always see all my neighbours wifi networks. With the wifi password cleared, it means anyone who can see my network, will see it's open and can use it (via the internet passthrough that's still configured and working) to access the internet. Without being able to get into the settings, I can't stop that without turning off the device!


I think this is a bit of a design flaw. It would be better if the reset button could respond differently to a a short press and (very) long press. The long press would return all firmware configuration settings to factory defaults.

Link to comment
Share on other sites

That's fixed it!


Thanks so much for your help.


Is there some reason why the 2.1.2 firmware couldn't also be made a rescue image?


Could I suggest mentioning on the support firmware download page that the 2.0.17 image is a rescue image and to try it if 2.1.2 doesn't work.


And for completeness (for others who may come across this thread):

I formatted the drive (so I knew it was clean), using HFS (i.e. OSX filesystem)

Via the USB cable I put the 2.0.17 pkg file (VoyagerAir-dev.pkg) in the root directory of the drive.

Unplugged the drive power cycled it (I had the wifi turned off).

After a minute or so, the blue wifi light started flashing.

It takes a LONG time to reflash - 10 minutes or so.

When it finally finished flashing I turned on the wifi and connected to the device (now back to factory default settings).

The device was working! Yeah!

I then used the web interface to upgrade it to firmware version 2.1.2.


Once again, thanks for your help Bill! Much appreciated.

Link to comment
Share on other sites

Hey, I got the Voyager Air 2 and I'm getting this error if my drive is formatted as ExFat which lets me place files bigger than 4GB on my Harddrive. If I use another Format the Wireless functionality works fine, but I wont be able to upload anything to my Harddrive manually if it is above the 4GB size. Obviously I want to be able to do both: Upload files bigger than 4GB onto the Harddrive and use Wireless functionality. How is this possible? I have tried the above method but to no luck because the Air 2 comes with 2.0.17 preinstalled so it wont need to update to the same firmware.

Any Ideas?


P.S: I have used Disk Utility in Mac and Disk Management in Windows for trying different formats

Link to comment
Share on other sites

  • 1 year later...
Hello, I hope i am posting this correctly but i too have this problem, or at least something very similar. I have 1Tb Voyagerair i loaded it with music pictures etc connected by usb on my laptop. I plugged it into port on router and can see it in router settings, i can connect wirelessly, i can see it through web browser and by android app and could use the drive, but in the last few days i can still see the drive but cannot see the files i put on the drive by any method i try. I have seen a couple of errors show up while trying to understand whats happened, one said the drive had not been initialized, another said something about metadata another said internal server error and also had one that said code 10. i can see the drive in device manager and also in disk management BUT in here it shows the drive as Disk 1, removeable, no media, i cannot right click and open or explore. I cannot even access it to update the firmware. i am hoping there is some way to factory reset it but, up to now have been unable to find if this is even possible. So please, please can anybody help point me in the right direction, thank you
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...