Jump to content
Corsair Community

K70 Led lock lights are not working.


Recommended Posts

I've tried switching from BIOS to 1,2,4,8. I tried to switch the USB port too. I don't really see the issue anymore but I know this happens a lot.


Basically, the lights that indicate whether capslock is on/off are not working. At one point, I would turn on capslock and every single one would light up. If I turned capslock off, it would shut all the lights off. I tried every solution from Google and the forums. I also don't know if this is another issue but the lights on the music playing and the mute button seem to be a lot more dim than usual. It's only these keys that seem to not light up. The mute button still functions and so does the volume indicator. I don't really see the issue.


I spilled something on my keyboard that was completely on the other side. It can't be that, so I don't understand the issue. I tried switching through BIOS, changing USBs, and restarting my computer. It also seems that when I go into Sleep mode, the LED light adjuster and the music buttons still are on. I don't know if that happens all the time, but it happens to me.

Link to comment
Share on other sites

I don't think you can do much to fix it. You can try reflashing the firmware but i don't think it would help.


Note: Warranty is void as you have spilled liquid on the keyboard.


Oooh, did not know that. Thanks for that, the liquid luckily didn't damage my keyboard whatsoever. I can live with it, it's not like I care about those lights, can't really see them regardless. I don't use the music player either, and my headset doesn't need to have the volume adjusted on the computer. I'm fine. Thanks for just letting me know I can't really do anything. I tried firmware too, I'm fine though haha.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...