Jump to content
Corsair Community

Keyboard K70/mouse m65 drop out issues


camshaft007

Recommended Posts

*** just wanted to add this****

 

If you are having any issue with your Corsair device make sure it is in a USB2.0 port and has been firmware updated in this 2.0 port as well.

 

 

 

 

 

 

Back once again :(

 

My M40 issue/ corsair could not resolve returned device

http://forum.corsair.com/v3/showthread.php?t=128376

 

New purchase M65 and K70 and I'm not impressed

 

K70 has key repeat issue and at time seems to no respond to commands(key presses) and the backlight leds flicker at times

Similar problem thread

http://forum.corsair.com/v3/showthread.php?p=718021#post718021

 

M65 once again has millisecond lag or hesitation

 

I have:

-installed all software and updated all firmware to newest versions

-MB bios is updated to newest

-ran driver genius and all drivers are up todate

-swapping USB ports no difference

-my old USB mouse no issues/ my PS keyboard no issues

 

**

Questions is it normal for a k70 backlights to flicker off/on maybe millisecond at intermittent times ?

Could this be a MB issue ? power supply issue? if so why would my old hardware work fine.

 

This is so frustrating please help

 

Ticket sent to support as well

 

-gigabyte MB

-intel i7

Link to comment
Share on other sites

update

 

-problem seems to be getting worse!!! 4-5 seconds of moving the mouse it will just stop and lag for a .5-1second.

 

-Then today the mouse stop working and the backlight went out, windows 8.11 indicated nothing, device manager said nothing.

USB showed nothing.

-plugged in old usb mouse/ registered and mouse started working.

-unplugged old mouse/

-unplugged corsair , reinstalled usb, mouse started working again.

 

-I unfortunately did not look at the mouse section under device manager.

 

Can anyone offer some suggestions were I should be looking if the mouse decides to drop out completely >?

 

-searching the internet I did find on this forum about setting the lift height to high, then back down to med.

I tried that and it had no effect.

 

ARG please someone help me, i'm going crazy !!!!!!!

The mouse is basically unusable..............................

 

**** update****

Going nuts I just tried changing anything

-lift height high, no effect

-report rate setting set to 8mm from 1mm, seems to have drastically changed lag. Used to do it consistently at 4-5 seconds.

 

Can anyone explain why a brand new OS windows8.11 and new MB can't handle 1mm ?

Link to comment
Share on other sites

Thanks for reply

 

I called corsair today because tech tickets take to long.

 

Suggested trying uninstall everything and reinstall devices in usb2.0 ports.

Then reflash firmware

 

As key repeating issue should have been resolved with 2013 firmware update.

But still possible to have hardware issue.

 

Will try this and swapping to my laptop to see if issue follows hardware.

Link to comment
Share on other sites

Not sure if any moderator is reading this but I would highly suggest that you guys add a sticky for USB 3.0 port problems.

 

And that

 

If you are having any issue with your Corsair device make sure it is in a USB2.0 port and has been firmware updated in this 2.0 port as well.

Link to comment
Share on other sites

Wanted to add some further info

 

In a attempt to isolate my problem my hardware support told me to boot into safe mode.

Which ended up fixing all the 3.0 port problems, then returned back to regular windows the faults returned.

 

So I highly suggest you move to 1.0/2.0 usb port and attempting to duplicate your problem.

As my key repeat problem was pinpointed to 3.0 port

 

good luck

C

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...