Jump to content
Corsair Community

Why does not my Corsair AX powersupplies boot Rampage 4 MB??


Recommended Posts


I ve my build posting error code B1 on my Rampage 4 Formula. Inward the motherboard for RMA and got it back with no issues on the board, but a possible power supply defect. Hence sent the Corsair AX750 for RMA, and the corsair guys were kind enough to send me back AX760i in return. Meanwhile, I also purchased a corsair VS650 before I received the RMAed AX760i and it worked perfectly. Now with the big grin on my face I plugged in the AX760i and it showed up the same B1 code with no display. Could it be possible that both the AX power supplies has the same problem?


My Spec :

i7 4930k, Rampage 4 Formula, 4X4 - 16gb G.Skilll memory, Asus DC2 780 and a couple of ssds


Meanwhile I pluged in the AX760i in to the other Asus maximus IV PC I have and it works perfectly. Now I am clueless.. what am I doing wrong??:(::(:

P.S. : This build worked perfectly for almost six months until a month back.

Link to comment
Share on other sites

Also the rampage has gotten a slight scratch at its rear.. The asus service centre guys said that may not be the issue because the copper is not exposed and the Motherboard boots fine with their PSUs as well..:(::(:







Link to comment
Share on other sites

Hi! I know you! ;):


I'm still waiting to hear back from validation on this. It sounded like a familiar problem to me, but I could be thinking of another board.


Hey Jonny Guru.. Its me again.. I did post in a few more forums as well. U could remember Rampage and AX powersupplies :biggrin:.. I guess this problems one of a kind.


I really do not know how to approach the asus service centre here in India again becuz their power supplies work well with my board. Also I had to give them my Processor and the cooler with the board for their testing because they do not ve spare 2011 proc for testing purposes.:(:


I have mailed the asus tech support for assistance. Hope they can help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...