Jump to content
Corsair Community

K90 Q key acting up


Recommended Posts

Hey guys, I've had my K90 for about a year and 7months now. Lately, my Q key has been acting up. Every time I press Q, random letters show up. This is what shows up most of the time when I press Q: eiopqruw. I literally have to delete the other letters just to get it. It's happened twice so far. First time, it just went away. This time, it's not going anywhere and it's driving me to insanity :(

Looked it up and I cant find anything about it. Any ideas?


This is me just pressing q:








Link to comment
Share on other sites

Same thing happening here but with multiple keys.


Here is 7an "unedited" version of these 2 sentences:


Same thuingr 7huapäpäeningr huegre 7bhut 7w<ithu 7mhultipäle keys.


HUegre 7is 7an 7"hunedited" 7vegrsion 7of 7thuese 72 7sentences.



Here are all the faulty keys I could find:


INS (on 6-block): delete

SPACE: space and 7

CURSOR UP: cursor up and +

H: hu

G: gr

Ä: pä

U: hu

W: w<

NUM 7: 7 and SPACE

NUM 8: 8 and 0

NUM 9: 9 and ,

NUM 0: 8 and 0

NUM ,: , and 9

NUM +: + and cursor up


BTW:When I switch off NUM-LOCK, things get even stranger. "7" will still trigger "SPACE" and SPACE turns into "HOME".


This is unacceptable for a product in this price-range - and one that's barely 15 months old.


Already (re-)flashed the firmware and rebooted PC, used different USB-ports for the keyboard but all that did nothing.


Tried an ancient MS Internet keyboard and a pretty recent Sidewinder X4 - both of which worked fine. So I'm pretty sure it's the K90 that's at fault here and not my PC/Mobo/USB-ports.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...