Jump to content
Corsair Community

Corsair M90 don't work after sleep mode/restart.


Recommended Posts

Well, to Corsair your 2 business day response time is a total lie as I submitted a ticket about the problem on the 18th of June 2014. To those who are wise and helpful here is a paste of my ticket I still have open with Corsair about my unfortunate problem with a great mouse I've had for a year and a half.




o Corsair,

My Corsair M90 Mouse has been working strong for the last year and a half since I bought it from Newegg until recently. The problem is anytime my computer awakens from sleep mode/restarts/turns on after being shutdown the mouse with turn on briefly during the initial loading phase of windows but then turn off. From there I have to use a different mouse to log in and then I unplug my corsair m90 and then plug it back in to get it to work, but only before I run the m90 setup software. When this problem originated a few days ago I orginally uninstalled all drivers/firmware and did a restart by downloading the newest software for the mouse. But at first the FwUpdater v1.12 wouldn't even recognize the mouse and the one time it did it said the flash memory failed. To resolve that I ran the m90 setup and bam the mouse was recognized and the firmware was successful. And I was hoping that was the end of it but no everytime the computer is rebooted I must redo it all.


[Paste] Additional Comments.


3 days later the m90 still gives me these problems.

Furthermore just as a continuation I woke my computer up from sleep mode and the mouse is lit up but the cursor will not move.


Additional Current Comments.


Today all I seem to have to do since the last two sleep mode awakens has been to unplug the usb for the m90 and plug it back in and both times windows installed the driver successfully even when the mouse was lit up but the cursor wouldn't move but as soon as the driver which I have installed already is installed through the automatic windows thing the mouse works, what the hell?




I really love the mouse. But I wish it hadn't started doing this, please anyone if you can help I'm open ears.


Ticket #6483828

Link to comment
Share on other sites

I don't know how to update my bios and haven't thought of it since it is a problem that occurred after the mouse working flawlessly since November 2012.

Also as a update the mouse now almost made it through a firmware update but it fails each time and only two led blue lights only light up.


And every time I've tried updating the firmware it gets stuck at this progress each time.



Then I'll try again and it tells me to unplug it and plug it back in then it fails again and tells me to try a new usb port and so on and so forth.

I have disabled the usb suspended power setting.

Link to comment
Share on other sites

Yes, over the last day I decided to see if the mouse would work on a w7 laptop.

The mouse was detected, the firmwear was able to update, and the driver installed on the laptop and the mouse fully lit up again.

So from there the firmware problem is fixed.

However now back to my desktop I got it to work as normal by again reinstalling everything.


However the original problem still exists of everytime I reboot the computer the mouse is lit up but the cursor won't move or as what just happened to me 10 minutes ago I awoke the computer the mouse didn't light up, so I unplugged the usb and back in as usual but it didn't light up so I troubleshooted the mouse in device manager and its like my computer forgot the mouses drivers as you can see in the picture. But after windows auto fixed the mouse lit up and again works... Until the next reboot that is.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...