Jump to content
Corsair Community

K70 3rd Line Not Working


Recommended Posts

I just found out when I booted my PC that the 3rd line of keys (tab to closing bracket) of my corsair k70 kb is not working. This is the first time it happened. Prior to that is grounded issue but no issues with the keys. I've been looking for a fix but can't find any threads. Please help.


Done testing with other PC same issue

Done testing different keyboard no issue

Tried uninstalling in device manager no success

PC is in windows 8.1, an update was installing prior to boot to windows. It was working before that too.

Link to comment
Share on other sites

1. I flashed the new firmware from the corsair site. That helped resetting the lights but the said keys are still not working.

2. Are you referring to the 1,2,4,8 switch at the top side of the kb? I tried switching it one after the other, that didn't help either.


If I try to move the kb to another USB port, the kb will suddenly act strange spamming the said keys and the set button light flashing.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...