Jump to content
Corsair Community

H80i was never recognized by system; tried all possibilities?


Recommended Posts

Greetings to all members.


I received my H80i a week ago, and I would like to install it in a new build. I´ve installed it properly, carefully assembling on the Intel backplate and checked all connections (mobo to pump, fans to pump, pump to SATA, pump to USB, etc.).


After assembling, I booted the system and a BIOS message popped up: “CPU_FAN ERROR”. In BIOS, I disabled fan controls to bypass all errors and proceeded to Win 8.1 first install. The LED of unit was on, so I assumed that the pump was running, but radiator block fans were running at a high speed, with extremely loud noise, but I thought that could be ok for a first install, and wondered if it could be less noisy after driver and software installation, what could allow me to control fan speeds properly.


After complete driver and OS installation (and rebootings), I’ve proceeded to Corsair Link installation. Rebooted system and the unit kept running super fast and super noisy. Corsair Link (2.4.5110, downloaded from product page on Corsair website) was not able to detect pump or fans, but detect other system fans (from mobo, case and GPU).


So, I was leaded to here, and tried some suggestions from users of this (GREAT!) forum:

- Changed internal USB port: not worked. I’ve tested all internal USB ports connecting them one by one to front side USB connectors of my case, and all were fine (found USB and mouse drives properly).

-Tried to connect/disconnect USB and/or SATA power connector (creepy…) while OS running: not worked

-Tried to “Scan for hardware changes” on DevMan: not worked

-Connected pump to external USB port: I used an alternative cable to connect the pump to external (back) USB 2.0 and 3.0 ports, without success. Tested all ports with USB drives (and mouse) and all are working

-Tested supplied USB cable: the cable is fine. I could detect power through it (connected to a mini-USB cell phone) in all ports.

-Registry trick: the “VID_1B1C&PID_0C**” keys are NOT on my registry.

-USB and HID devices on Windows DevMan: Checked all items, none could be related to H80i. I installed a software called “USBView” that found a weird “USB mass storage” connected to USB hub, but I could not access it.

-Uninstall/remove Corsair folders/reinstall Corsair Link versions 2.6.5214, 2.5.5145, 2.4.5065, and finally, 2.2.0 (different tries, obviously): Tried to detect device and check for updates, but the software said that “could not detect ‘anay’” (sic) devices connected. In other cases, CL just crashed. Very time consuming, a lot of reboots and coldboots, without success.

-Removed AI Suite software with removal tool from Asus forums: not worked, fans kept trying to fly (:roll:) and not found by CLink. Tried to uninstall/remove Corsair folders/reinstall same as above after removing Ai Suite, and still not worked. A lot of reboots and coldboots again.

-Windows 8.1 fresh install: I wondered if a fresh install could repair USB connection problems. So, I’ve installed OS and all mobo drives again. Not worked.

-Windows 7 fresh install: I wondered (again!) is Win7 could better handle the drives. Formatted, installed Win7 and all drives. Not worked again.


Some members would recommend me to flash firmware, but I think that is impossible, as pump is not detected by system, preventing from communication with software. And I’m considering a RMA (already started conversation with store), and would not try anything that could avoid warranty. And, I’m not sure if I’m fully competent to it (:D:).


After all these tries, I would like to know if there is any other procedure that I could test.

Could you help me please?


Thanks in advance, and Congrats for keeping the community!

Link to comment
Share on other sites

Sounds like there's two separate problems there.


1) the fan error normally comes from the fan cable not being plugged in to the right slot. Can you see any header labelled 'CPU FAN' or similar on your mobo? Mine was on the MIO board, which is an alienware propriety thing. That's where the cable needs to go. If that's what it's in then are any connectors bent?


2) what you're describing about USB connections sounds like a device conflict. Important question - did you attempt connecting it with *anything* else USB plugged in? I got the same show... In my case it was the keyboard that was conflicting. Pulled it out and tried another slot... Link connected immediately.

Link to comment
Share on other sites

Hi Jaeger, thanks for answer.


1) I checked those connections. My mobo has 2: CPU_FAN and CPU_OPT. Both are in perfect state, no bended pins or burnt signs. I forgot to mention, but tested the molex connected on both, and did not worked in any way. Besides, I connected the fans directly to these ports, and they worked, running without control and in a noisy way as like connected to pump.


2) Unfortunately, I have only one keyboard and mouse set that uses an USB dongle, so I couldn't test the unit without *anything* else connected via USB, but tried to connect the mouse+keyb dongle in another port(s), without success. I think that's a good point to look for conflicts here, but as I mentioned before, I looked for conflicts checking the Win DevMan and through the USB View software. USB View showed a strange "USB Mass storage media" connected to the same port that H80i (would be) is connected, and my Mouse+keyb set is shiny depicted on another port on another USB Hub. Even in this case could be an address conflict?

Link to comment
Share on other sites

1) that's weird. Do you get a bios error if you boot up just with the fans connected to the mobo? If you don't, can you verify your h80i is actually working (I.e. Lights on and cpu not idling at 70C+)? It could be that the ribbon cable on your water block is screwed.


2) Try it without *any* keyboard. Seriously, standard windows HID drivers are extremely prone to conflicts (it's why most hardware companies write their own drivers for anything more complicated than memory sticks - corsair are an exception). You only need your mouse to fiddle with Link.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...