Jump to content
Corsair Community

Corsair Link won't show up


Recommended Posts

Hello everyone,

I just tried to reinstall my Corsair Link, because the older version (installed about 5 or so months ago) won't let me change LED lights on my h100i pump. So i deleted the older version and installed the last one (2.6.5214). Then i plugged back the h100i via direct usb cable, connected to my front panel (not to my mainboard because I was still having issues with that method).

Anyway, when I restarded, I tried to open my Corsair Link, but it won't show up! Basically what happens to me is that if I try to right click the little icon near the clock and set to Quiet, Balanced or Performance mode, it works perfectly, but when i choose the "Show CorsairLINK" option, nothing happens!

I tried to reinstall, reboot, try different Corsair Link versions but still nothing has changed.

This is so frustrating!!


Asrock z87 extreme4

i7 2600k

Windows 7 Professional 64 bit






Link to comment
Share on other sites

chances are your link thru all the installs is pointing to another usb header.

you may try uninstalling including the appdata folder,,unplug the usb connector,,,do a FULL COLDBOOT,restart to windows...then shutdown and reconnect link,then do the reinstall.

Link to comment
Share on other sites

tried. Still nothing it's happening. I can't figure out what or where the problem is! I'm gonna throw this garbage outside.... Seriously, I hate when I can't figure out where the problem is and can't solve it. It's really frustrating :[pouts:
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...