Jump to content
Corsair Community

H100i LED Change HELP, Firmware Downgrade?


Recommended Posts

Hey everyone. About 4 months ago I purchased an H100i on Amazon. A few weeks into owning, the LED lights would change every time I would restart (after it was completely off). I would start with RED, then it would boot to PINK. I'm not absolutely sure, but I believe the firmware was 1.0.5. Anyways, I had a problem with the fan controller on it, so I had to RMA it. Corsair then sent me a brand new unit, and I didn't have an problems with the color changing.


However, I was changing the fans on the radiator, and one of the screw holes was completely striped. I assumed that this would cause a leak in static pressure, and instead of RMA'ing it again through corsair, Amazon was nice enough to let me return that one, and give me an exchange for a new one. (I'm sorry corsair, but at least Amazon accepts changes and returns with a prepaid postage label, rather than having us pay to send it back)


So now, on my new one I was sent from Amazon, I believe the firmware was once again 1.0.5. But I don't believe that was the problem, as the lights were completely okay. They wouldn't change at all on startup.


The issue came after I tried to install the beta version of Corsair Link. Once I installed it, it told me that there was an update in firmware for the h100i (1.0.7). I thought it would be a good idea to install the new firmware, so I did. Now, from what I believe, upgrading to the new firmware was the cause of all the problems with the LED lights changing.


I'm trying to convert back to 1.0.5, but I cant. I saw a post made by RAM GUY on these forums, with a link and .zip file for 1.0.5. Whenever I try and install it, or download it, it shows up as "attachment.php"


Is there an actual link or .zip file that I can download, to convert my firmware to 1.0.5.? Right now, my LED color on the H100i is bright pink, and it is very annoying. I don't know if this is an actual problem, but it seems to me that Amazon is sending older versions of the H100i, and Corsair is sending out new versions.


I would really appreciate some help around here. Thanks

Link to comment
Share on other sites

Try a different browser and download the file.


WOW... Thank you so much Toasted. That downloaded the file. I just installed Chrome, and everything worked. IE is still my favorite, but there is a lot of problems with Internet Explorer. Im running 1.0.5. again. Thank you so much

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...