Jump to content
Corsair Community

Corsair K95 unique problem, help?


Recommended Posts

I don't know what has happened but my T, Y and G keys have all stopped operating correctly. When they are pressed, the input on screen is instead complete jargon. For example, if the T button is pressed, on screen will appear "#; ADFGHJKLS" when the Y button is pressed "#; GHJKL" does anyone have any clue as to what on earth has happened?


All other keys work fine, I have tried it on other systems, it is 100% the keyboard's fault. I have flashed the firmware twice.


Has anybody heard of this issue before or has a way to somehow fix it? I am afraid those keys might just have died for some reason,

Link to comment
Share on other sites

I'm having a very similar problem with my K90, but not as extreme.


Running Windows 8.1, and the problem only seems to happen after playing BF4 or the BFH beta for awhile, but those are really the only games I'm playing at the moment.


Here's me typing the alphabet into notepad when it was happening:

A B C D E F G H I] J K L M N O P[ Q RT S RT UY V W x uy z


Each key always produces the same keystrokes when it's happening. Shift usually produces a shift and a +, in game, q produces a tab character as well, etc. After I'm done playing, the problem goes away on it's own eventually, but unplugging the keyboard doesn't do anything, nor does uninstalling the keyboard driver and letting it redetect it, so it doesn't appear to be a driver issue, but rather a bizarre hardware issue.


I have a ticket into Corsair for this issue as well, but it seems like they are going to suggest an RMA, but personally if it's a simple fix, I'd rather do that, than hassle with an RMA.


Tried plugging in a different keyboard, and it's not happening with that one.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...