Jump to content
Corsair Community

Corsair Link sometimes doesn't read Processor Temp?


Recommended Posts

Hey Everyone,


I have this build for a few months now. Everything is going well I have 16 gigs of ram, I7-4770K, decent graphics card, and a H100I Cooling system. When I did Prime under load it hovered around high 70's and maybe hit 81 for a few seconds and when it's idle it's at a cool 25 degrees.


I'm happy with that temperature, I don't know much about computers. [unless it's very concerning, but from I read it seems to be the norm. When I game the highest I hit on like Battlefield 4 is 66].


What I'm concerned about is this morning my Corsair Link program didn't read my Processor temperature, the field was just blank. I tried restarting, nothing. I knew it was working cause Coretemp was showing me all of my cores...


So I tried uninstalling and reinstalling my Corsair Link and it worked! However when I went to restart the computer it went back to not working. I then did a Prime Test to see if I went into any abnormal temperatures for the computer [i did not. it was within +/- 1/2 degrees] and I physically checked to see if all my fans were working which they are (The light was even on)


So I shut down my computer, turned it back on and it's working again. I did it again after going to work and it's working again.


I'm just wondering if this is just a bug and shouldn't be something to worry about? Since the fans were working, Prime ran great, Coretemp read everything, and I could still access my fans on Corsair Link.


Image of the desktop setup without the error:



Link to comment
Share on other sites

If i remember correctly, there is a conflict issue with AI Suite and Corsair LINK. Close AI Suite and related services and see if the temp readings come back.


If you are using the LINK readings for CPU temps when stress testing, i don't recommend it. Use something else like Core temp as its better than the LINK reading. The LINK readings are the averages of each individual core.

Link to comment
Share on other sites

Thanks for the Response,


Closing AI Suite doesn't bring my fans back in Corsair Link.


When my computer started I had the I7 Temp error, so I closed the program and re-opened it and it appeared again.


I still think the program is buggy because of this, because if something was wrong the I7 Temp thing shouldn't have come back then.


I don't think I'm too worried about not seeing the fans cause I can control them through AI Suite and probably the BIOs if I really wanted to, and like I said my temperatures (From Core Temp) are 81, 79, 78. and 76 when loaded on Prim 95.


Unless of course I should be worried and I'm just ignorant.

Link to comment
Share on other sites

I am having this same problem since install. I have full fan control, all other readings are properly displayed, save H80i Temp, which is permanently 0.0 C (not blank). Additionally, I do not have any graph data. I can change fan speeds manually and set profile curves, but that isn't very helpful if the pump thinks my temp is 0. Of course, it isn't and HWMonitor tracks my 4 core temps. The pump is working and I have much improved cooling over my old H50.


I am running Link v 2.6.5214 and firmware version 1.07. I tried rolling back to 2.5.5145, but was unable to read any sensors with that version and received a consistent Microsoft Net Framework error. I am running MS Net Framework 4.51 and it is fully up to date. I have no pending Windows updates and no hidden updates (Win 7 x64 sp1). Motherboard and Bios are both up to date. As this rig is 4 years old, there haven't been any recent changes to those areas.


I have removed all other 3rd party monitoring programs from this computer (Riva Statistic, PC Meter, Real Temp, HWMonitor) and re-installed Corsair Link 2.6. This did not change my status. I have also re-installed Link in each of my 3 MB USB slots. The problem was consistent across all three and I have full USB function from all three slots. I have removed all USB peripherals, except the mouse and keyboard, and re-installed Link without solving this issue. I have re-installed Corsair Link now with more than 15 different configurations, and the problem is consistent across all of them.


Ideas? Is this a Microsoft Net Framework Problem? Do I have a bad temp sensor on my brand new Corsair H80i?


EDIT* I have re-installed Microsoft net Framework 4.5 and the 3 updates from MS to bring it fully up to date. This did not solve my problem with 2.6.5214 and the prior 2.5 version remains unusable. Graph issue resolved - user error. I wouldn't have thought to click the completely blank space to make something magically appear in the config panel.

Link to comment
Share on other sites

I finally have the Link program up and running by rolling back two versions to 2.4.5110. (2.6 - no cpu temp reading/2.5 - MS Net framework error prevents operation). I don't know if this will help anyone else or not. I can't ever remember rolling back two versions of a program before and finding it improved.


Also, for anyone new to program, with 2.4, under the the Group Tab, you MUST drag the sensor dials into the appropriate group in order to make the LED light function in temp scale mode and to allow the fans to follow their temp curve. This didn't seem to be an issue with 2.6.


EDIT: Fans do not follow custom fans curves, regardless of settings. Glorious.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...