Jump to content
Corsair Community

AX 1200i usb dongle driver not digitally signed error


Recommended Posts

As the title states... the USB dongle is "!" under device manager and my AX 1200i is not being detected by the corsair link software windows 8.1 64-bit. It worked fine under windows 7 bit.


I've tried the registry hacks.. that got my H100i going, but...


"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"


Aside from the obvious, anyone know what might trigger this error? Any help would be appreciated.


*edit* had to uninstall the device from device manager after uninstalling corsair link. I needed to check the box "delete the driver for this device" then reboot, re-install corsair link, reboot, now working.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...