Jump to content
Corsair Community

Corsair AX1200i turns on and off intermittently


Recommended Posts

I had a situation some months ago when the built-in SATA drawer of my old case, an Aerocool Strike-X, literally caught fire. I was sleeping and woke up when the flames was reaching almost 20 centimeters high. Even whit the case in fire, the whole system yet was working normally, I entered the command manually to shut down the Windows before to handle with the fire. The system turned off properly.


The flames was dense and I couldn't put it down without water. Yes, I had to threw a bucket of water to put the fire down. Fortunately (if I may call this way), the case was huge, and the water just soaked the HDD aread. Mobo and other components was at the back side, far from the SATA drawer.


Well, I disassembled everything, dried each part and let all out of use for some weeks (to dry). Everything seems to be OK visually. Just one of the modules of the power supply (until then, an OCZ 1250W) was inutilized by the melted plastic at the slot.


A month later, I bought a new case and I reassembled the PC with the same parts. And the PC won't worked. The MOBO turns on, all fans and LED work like everything was alright, but none screen signal and, after a few seconds, the power supply turns off and on sucessively, entering in a cycle with no end and no signal of BIOS or screen signal.


I've done all kind of tests with no change: a stick of memory by time, other GPU, reseating CPU and watercooler. Than I tried another power supply, humble, with 500W (don't remember the specification), and the PC worked. So, you may though: problems fixed, have to buy another power supply. I though this too.


So, last week, I bought a Corsair AX1200i. I assembled the PC with this new PSU and, to my entire stupefaction, the problem persists. The power supply keeps turning on and off forever. I tried another different PSU, this time a Cougar CMX700W (from a friend), and the PC worked properly. Windows had booted and worked just exactly as it should be. But when I install again the Corsair AX1200i, nothing.


At this time I had accepted all my bad lucky and thought that the new PSU came damaged, but I had to be certain, then I tested in a friend PC and it's working perfectly for hours straight.


Unfortunately, all indicates some malfunction of my MOBO, but why it seems to work perfectly with some "weaker" PSU?


I guess this is related to some protection device of Corsair AX1200i. It's possible? If so, it's impossible to use this PSU with this MOBO anyway? Which could be the problems to trigger this kind of protection in PSU? And the golden question: what I have to do, besides praying??? =]


Please, help me!


Sorry the bad english.



- EDIT - - - -


Maybe there is a light at the end of the tunnel. In a talk with a friend (the owner of Cougar PSU), who is helping me with the tests, he told me that in some rare cases, he washed the some motherboards with isopropyl alcohol to remove possible oxidation points and others things which may cause overcurrent. Now I'm betting all my chips on this! I'll report any news.


SOLVED! The isopropyl bath was a success! So, if you have the same symptoms, PC working with common PSU but won't with high-end PSU, it may be just some overcorrent in your MOBO. The isopropyl washes most of possible causes. Hope this can help anyone. =]

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...