Jump to content
Corsair Community

H100i Not being detected in Corsair Link Softare


Recommended Posts

Hello Everyone,

I just installed a H100i for the first time tonight.

Everything went well with the install.


I installed the Corsair link software that was in the download section of their site. Rebooted and the software did not pick up the device.


I made sure the USB 3.0 drivers for my MOBO were installed.

I moved the USB for the device to a different port on the mobo and got the same results.


I uninstalled the link software and installed the latest beta version, the h100i is still not showing up.


Anyone have an idea of what i may have done wrong?


My setup is:

Mobo: Gigabyte Z68X-UD3H-B3

CPU: Intel i7 3770k

OS: Windows 8.1 64bit


Heres what shows up in devices:



Here is what i do see in the Link software:


Link to comment
Share on other sites

well at this point ive tried all 3 USB ports on my mobo.

Tried 2 versions of the software.


my idle temp is 30-40oC, and if i try to stress test the cpu goes over 100oC in seconds, so id say this device is not working at all. My previous air cooler better than that.


probably have to start the refund process with newegg tomorrow.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...