Jump to content
Corsair Community

H100i problem


Recommended Posts

Hi, I wanted to update to the new corsair link version 2.6.5214 and after updating to the it it asked me if I want to update the firmware and restart, after restart one of the fans kept running at max speed and never wanted to change speed and led color kept going pink and I had to set it to my favorite color each time, and then the led started to go off and computer freezes and bios couldn't detect pump anymore and then corsair link stopped detecting the H100i at all, plz help me.


Thx for ur help in advance.


Best Regards,



Update 1: I tried to unplug the H100i from power and re-plug it again MANY times and it finally can be detected again, is there a way to go back to the default firmware, I still can't control fan #2 it keeps running at full speed and never changes n matter what I do and also color goes to pink by it self.


Update 2: I switched back to version 2.4.5110 and managed to get fw 1.0.5, the led color issue is solved and also the H100i gets detected all the time now, but I still can't control fan # 2, it runs at full speed no matter what I do, if any one can help I'd really appreciate it, thx.

Link to comment
Share on other sites

Thx David for ur posts, I saw them when u posted and I apologize for not answering sooner, but I was, and still, very sad and mad at the same time, the h100i ended up dying and it took with it 2 fan header from my dear motherboard, I rly dont know what to say, this is one of the worst things that happened to me, I have no words to describe how I feel, thx again.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...