Jump to content
Corsair Community

H100i Corsair Link Problem


Recommended Posts

Hi Need help,


I bought a new H100i to upgrade my system from air cooling to water cooling. I exhaust myself to make it work so ask for help. The following are the key points:


The bois always detect 0 CPU-fan RMP. I collected pump 3 pin to motherboard CPU pin. Is the 3 pin collector broken?


Corsair did not detect H100i at all, but showed other system temperatures such as CPU and GPU.


I was able to start window and install Corsair Link and tried 245110, 2-6-5245 and 2-5-5145.


At one time, 5110 detected both pump fans and pump. The system seems to be in a state of continually detected and disconnected as the pump RMP periodically to be 0 (probably one second)and then 2100 around for such 30 second. and the pump fans also running at the same cycle from low noise to high noise periodically. But after sometime. The H100i is completely disconnected from Corsair Link.


When installing 2-6-5245, it also suggested to update the firmware for H100i. But failed and the popup window asked me to check USB connection. But I am sure they are connected correctly.


Now my system showed that Pump RMP is zero no matter what I tried and the pump fan were running the same cycle from low noise to high noise periodically and continuously and I cannot control it because Corsairlink did not detect it.


Despite of all these symptoms the pump seemed running constantly. I can see the CPU temperature remain 32 C idle and 49 max when play BF4 OC 4.2 Hz. This 10 degree less than my air cooler NH-U14S.


I exhausted all my methods including some means suggested on this forum. Right now I am thinking that non detection on the pump by the system is the main reason for all of these symptoms. I tend to believe that the connections (fans and USB) to the pump have low quality and cause the system cannot recognize it correctly, because even I did not install Corsair Link, the pump and the pump fans behaved the same way.


Could some one put insights to my situation and decide if this is Hardware issue or not?


I bought this from Memory Express and they have 7 days of no reason return and 30 days faulty exchange policy.


Thanks and look forward to hearing from you.

Link to comment
Share on other sites

I temporarily connect pump fan to CPU connector on MB and put pump 3pin to a cha fan connector and run the system without the monitoring of pump. The pump LED sometimes red flash and sometimes Red constant.



Link to comment
Share on other sites

  • 2 weeks later...
IDK I think the Corsair Link software is soo buggy. My Link shows 0 For pump RPM Fans and Temp. I've uninstalled and re-installed other versions and different problems. Like the LED would stay pink and I couldn't control it. Very frustrating. Finally I found a version which I have no clue as to why there are soo many BETA but found one that seemed to be working like it should. I got it all configured and now it shows 0's. I just got fed up and left it. It seems to work like the way I set it LED and all. I am a little disappointed in Corsairs ability to put out decent software. Link should have an uninstaller and have compatibility with other software. You may have a conflict going on with other Monitoring software.
Link to comment
Share on other sites

Found this an hour ago because I was having similar problems with my H80i.

Go into the registry and look for HKLM\SYSTEM\CurrentControlSet\Enum\USB\VID_1B1C&PID_0C04. For each port/path string you see under this (numbers and ampersands smushed together), open the "Device Parameters" and change the FOUR DWORD settings to 0 (AllowIdleIrpInD3, DeviceSelectiveSuspended, EnhancedPowerManagementEnabled, SelectiveSuspendEnabled). Reboot.


He means the 4 words AllowIdleIrpInD3, DeviceSelectiveSuspended, EnhancedPowerManagementEnabled, SelectiveSuspendEnabled, all of which were set to 1 by default in my registry.


Everything is detected now. BTW, I am using the latest beta http://forum.corsair.com/v3/showthread.php?t=118618 though I don't know if you actually need to use that version or if the stable will work just as well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...