Jump to content
Corsair Community

M90 behaves strangely after resume in Win7 x64


Recommended Posts

As the title says, my M90 is behaving oddly after I resume from standby in Win7 x64. I've tried unchecking the boxes for "allow Windows to turn this device off to save power" for all of the applicable root hubs and host controllers, to no avail. I've also tried the ForceHCResetOnResume registry hack as described on the MS site, not to mention disabling selective suspend in the power settings, and I still have the issue of the mouse not coming "alive" after a resume until about a minute later. This happens whether I use the mouse buttons or the power button to resume from suspend.


With selective suspend set to ON, it gets worse. Trying to resume from suspend reboots the PC in that case.


Here's where it gets interesting. Without doing anything else (like moving the mouse to another USB port), I can reboot and select Windows XP Pro x86 (dual boot), and suspend works beautifully. The mouse comes on immediately after it resumes, and it works just great. The Corsair software and driver is installed in XP as it is in 7.


If I plug in my Logitech mouse and allow Windows to install the driver (the MS one), it works beautifully right out of suspend in Windows 7.


I put in a ticket about something similar to (if not equal to) this issue in January, and still it sits there, with Corsair never having done anything about it.


Is it possible that the 32-bit Corsair driver is insufficient for the 64 bit OS?

Link to comment
Share on other sites

There are? I did not see an option for x84 drivers. Is it a dual install package with both types in it? I don't see any other downloads for the M90, so I am guessing this is the case. I guess I never considered that they might be included together (doh!), since so many other drivers have separate x86 and x64 versions. Thanks for letting me know.


The problem is fixed now, though I am still in the dark about why it worked resuming from XP perfectly but not from 7. I solved it in this case by changing a setting in the computer's UEFI (BIOS). Internal PLL overvoltage (an overclocking setting) was set to enabled. It is known to cause issues with sleep mode... but it works perfectly in XP even with it on, so it seemed like that was not it, or at least not all of it.


A similar thing used to happen intermittently on this same computer as well as my Phenom II system. In about one in four or five boots, the mouse would not function at boot time. I had to unplug it and plug it back in to make it work. That was the issue I wrote the ticket about in the Corsair system. It is no longer doing that, thankfully.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...