Jump to content
Corsair Community

Having problems getting my RAM to work at 1866Mhz


Recommended Posts

I have input my entire spec as best as possible on my profile here so you should know all the details.


I have tested the RAM at default 1333Mhz with memtest86 v5 and there are no errors after multiple passes. However when I either enable the XMP profile or input the settings from the profile manually I have errors even on the first pass. Sometimes there is 1 error, sometimes 8 errors or even 350. I only get errors when going above 1333Mhz. Obviously the RAM is good, else I would have errors at it's default low speed.


I do not know what is going on. My Motherboard is that new that there is no additional BIOS updates other than the one that originally came on my motherboard. I have tried disabling all power-saving features and turbo mode for the CPU. I have tried putting in settings from the XMP profile, nothing works.


I have talked over with a friend of mine and nothing we have come up with has made the errors go away.


I would appreciate some help with this.





Link to comment
Share on other sites

It may be the cpu has issues running the ram at that speed. You should be able to get 1600mhz pretty easy tho. May to to loosen timing a but tho. Say they are 9-9-9-24 at 1600, then run them at 10-10-10-28 at 1600. Or bump cpu core voltage up a bit and memory voltage. Say you get errors at 1600 9-9-9-24 at 1.5v then bump it to 1.55-1.6v with same speed and timings. AMD cpu are quite troublesome at higher speeds sometimes. If this doesn't work run 1 stick at a time at the speed you get errors with and see if 1 stick gives errors and the other doesn't that means you have a faulty stick.
Link to comment
Share on other sites

After a lot of messing around I have some news. Bearing in mind that this ram is 9-10-9-27. I got it to work at 1600 when set to 1.65 volts. However setting the multipler to 9.33 to get to 1866 caused errors. But a weird thing happens on memtest86. With the previous ram I had from another company it would change the details based on how it was set in the bios, so the speed and timings would be different but with this corsair ram it always says 933Mhz and 10-11-10-27, which is weird because it is not 10-11-10-27 it is supposed to be 9-10-9-27 which is why I paid the extra money for the smaller timings. But all the confusion aside I put the multiplier back to 9.33 (without the profile enabled), voltage at 1.65 and altered the timings to 10-11-10-27 and it successfully completed 1 pass without any errors at all.


Is this normal? Why would I have to use non-standard non-spec timings on the spec speed? It is supposed to be 1866Mhz 9-10-9-27 at 1.5v yet it only works at 1.65 volt at 10-11-10-27.


Can someone help me understand this?



Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...
Can someone post correct settings for 9-10-9-27 1866mhz for amd/gigabyte?


I am using Intel i5-4690k with Vdd_DRAM = 1.5V. But I would think that AMD or Intel shouldn't matter. Here is the full timing configuration that my ASRock Z97M OC Formula motherboard reports.




Try it and see if it works.

Link to comment
Share on other sites

  • Corsair Employee
Do you know if your motherboard has an option in the BIOS called DOCP? if it does, try to enable it and manually change your DRAM voltage to 1.6v and force input the relaxed timings, 9-10-9-27. You may have to raise the CPU/NB voltage to .1v over the DOCP setting.
Link to comment
Share on other sites

  • 2 months later...


This topic is now archived and is closed to further replies.

  • Create New...