Jump to content
Corsair Community

CLink is making me mad!


Recommended Posts

Hi guys,


today already made a thread about high temps of my h80i. Fixed.


But: I've now problem with the software.


It crashes. I had a successfull installation and everything worked fine. But after about 20 mins of computer being ON, whenever I "Show Corsair Link Panel" (or something like this) it shows me my "layout" of fans etc but when I click on anything it just crashes (CorsairLink has stopped working blah blah...).


I have already uninstalled and deleted files from %AppData%, restarted PC and reinstalled it from Corsair's website but still no go. Can't even change my profile.


I could try older version of this (as it did update itself) but please give me a link/s as I couldn't find any older than current one.


Thanks! :)




I am running this as Administrator, but also in Compatibility mode (tried all possibilities) but no go... still a crash.

Link to comment
Share on other sites

Hmm I did attach the side panel.


But then I found the previous version and now it's fine. Apart from that the LED doesnt change when CPU temp rises (I did set it to do so but no go). Unless it's meaning of the liquid inside when it hits certain temps?

Link to comment
Share on other sites

Hmm currently all is fine.


What about the LED changing with higher temps? this doesnt seem to work at all. Even when I set 20*C for lowest (white LED) 25 for mid (Red LED) and 31 for high (blue LED) it stays white, even though CPU is hitting 48*C and liquid is around 30??

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...