Jump to content
Corsair Community

(Undetected USB) H80i Not being recognised


Recommended Posts

I have been trying to figure out a solution to why my H80i isn't being recognised at all on my computer, it shows up as "Unknown USB Device (Device Descriptor Request Failed)". I have tried many different solutions including :


- Uninstalling the "Unknown USB" from device manager,rebooting and then letting it update the driver.


- Using a USB A to USB mini running from the waterblock to the outside of my case into a back USB port (tried all of my USB ports)


- Regedit.exe trick were you change files in "1B1... Something" But i don't even have that folder because its not recognising my h80i


- Unplugging from power supply and waiting 10 minutes then rebooting with no USB devices attached.


- Many diffrent Corsair Link versions (each time uninstalled with revo uninstaller to get rid of the old Link files)



My cooler works fine, with the fans spinning (loudly) and the corsair logo lit up white. Any suggestions would be gratefully appreciated. Thank you


- Jamie

Link to comment
Share on other sites

The same it was for me.

I used a MINI-USB Type B cable that i used for my old smartphone and connected it to a USB 3.0 Port.


The difference between USB 2.0 and USB 3.0 is the power the port can supply.


Try to use a usb 3.0 port and it will work!

Link to comment
Share on other sites

I have recently tried it with another laptop and it appears as "Unknown device" and i tried uninstalling it from device manager and rebooting... but the same thing happend again so im guessing its a faulty unit :/
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...