Jump to content
Corsair Community

H100i LED Suddenly Stopped Working


Recommended Posts

I have made a few attempts to contact support in relation to a problem I am having with the LED on my Corsair H100i, but haven't heard anything back so don't know if I am doing something wrong.


About three weeks ago the bright white LED start to get dull and then I noticed is was a strange red/yellow colour. Then I noticed it was flickering at times. And at last on Saturday last I noticed it had stopped lighting altogether.


My first concern was that the cooler had stopped working so i logged into the Corsair Link on Window 8.1 and checked the fans were working - Corsair link reported they were working properly so that was a relief.


So first checks where to make sure none of the connections were lose - all ok.


I then tried disconnecting the USB connector and power at board end while computer was off to see if it would reset the LED. I reconnected them and started the computer but still not working.


I tried swapping the USB to a different USB Header and no luck.


Lastly I tried updating the Firmware to the latest version available on the Corsair.com website.


I have no idea what I should try next and welcome any suggestions you have as was hoping to make some upgrades to my computer components and want to make sure everything is working first.


Thanks a million in advance for any help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...