Jump to content
Corsair Community

H100i pump, fans, and LED not showing in Link 2.6.5214


Recommended Posts

After opening my PC to install a new video card, (It was unplugged for about 15 minutes) I opened up the corsair link software after rebooting to adjust the settings to account for the extra heat, and found that the fans, pump, and LED settings have all disappeared.


I tried doing a clean install of the software, but with no effect.


The new video card temperature and disk drive temps all show up fine.


I have also tried re-seating the fan connectors at both the water block end and the socket end.


Has anyone else come across this issue? Any workarounds?



Link to comment
Share on other sites

Ok. Strangely enough, It just asked me to update the firmware. I did, and then restarted my machine. It then said that it detected new devices that it needed a reboot to connect to. Again, I restarted, and then magically, it all works again. Everything is displaying properly and responding well.


I really wish I had a fix for anyone else who has run into this issue, but it just worked itself out.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...