Jump to content
Corsair Community

How do i check what firmware i had before i flashed?


Recommended Posts

My problem is this, SSD disk is Corsair Force GT 240GB, after i updated it to 5.05 it has been unstable. The SSD disconects from the system and just rebooting with reset switch dont help. Have to manually turn computer off and on with power switch. Now what i need help with is to find out what firmware i flashed from since that worked flawless for soon 2 years or something. I used Corsair SSD toolbox to flash.


Edit1: Also where can i find older firmwares? I tried looking on forum but they just show recent once from what i can see?

Edit2: I think i found it here http://forum.corsair.com/forums/showthread.php?t=117994 gonna see if i can downgrade to second newest and see if system will be more stable, not impressed by corsairs after the recent update and this has left me in mood to go for samsung drive next time tbh.

Edit3: It runs the fw update of the older fw,s but it dont actualy downgrade... If this is intended this ssd is going in the garbage.

Link to comment
Share on other sites

After your update if you still have issues, we strongly recommend the following steps:


1. Complete clearing of the BIOS. This is a good idea after any firmware flash of any device.


2. Secure erase the SSD. For some users, cloning of the drive works, for others it does not. This may be dependent upon the cloning tool used.


3. A clean installation of the OS if you experience instability after a BIOS clearing and secure erase.


UPDATE YOUR BIOS. As always for users with issues, we recommend that you update your motherboard/notebook to the most recent BIOS before attempting to flash your firmware. This may or may not resolve your issue but it is an excellent first step. Quite a few boards/notebooks have been given SSD specific updates over the past few months.


Source: http://forum.corsair.com/forums/showthread.php?t=117994

Link to comment
Share on other sites

I saw that, the bios got nothing to do with it and already at newest version. Secure erase because of a fw upgrade is no go, lazy coding will only be rewarded with the ssd being replaced since i have to reinstall whole OS anyway then. Same with last, your post didnt help me at all, but ty for trying atleast.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...