The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 04-10-2020, 10:04 AM
14js 14js is offline
Registered User
 
Join Date: Apr 2020
Posts: 1
POST ID # = 1040793
14js Reputation: 10
Default K70 RGB MK2 - Issues

Good afternoon all,

Received my K70 RGB MK2 yesterday and have had problems from initially plugging the keyboard in, i have been round and round the forums and google and no fix currently!

When first plugging in the keyboard worked fine, after 60 seconds the keyboard was unresponsive. I have tried the soft reset (holding esc whilst plugging in) The keyboard booted back in red only mode, i unplugged the keyboard and went back to my XTRFY (piece of S***). This morning trying the K70 again i experienced the same issue.

I updated the keyboard Firmware via Icue, i had a notification saying one or more of the user profiles were corupt so these were cleared.

Any other suggestions welcome, racking my head as want to get using this beauty!

Thanks.
Reply With Quote


  #2  
Old 07-13-2020, 01:20 PM
palary palary is offline
Registered User
 
Join Date: Jul 2020
Posts: 1
POST ID # = 1053815
palary Reputation: 10
Default

Welcome to the club! :D

So the issue was the keyboard was unresponsive after 60 seconds?

Have you tried using other USB or other PC/laptop? Same issue?
Reply With Quote


Reply

Tags
issue, k70, k70 mk2, keyboard, notworking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.