The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 30 votes, 5.00 average. Display Modes
  #46  
Old 03-29-2013, 12:14 PM
Wezelkrozum Wezelkrozum is offline
Registered User
 
Join Date: Feb 2013
Posts: 22
POST ID # = 643658
Wezelkrozum Reputation: 10
Default

Quote:
Originally Posted by Wezelkrozum View Post
Thanks for the update guys, but the previous drivers for the Vengeance 2000 headset sounded a lot better. Some issues i'm experiencing:
- The bass sounds like I've put a subwoofer on my head in any mode
- Everything sounds dull/muffled. The fresh, crispy and clear sound (in for example movies) is gone. (With the previous driver I was able to hear sounds in a movie of which I didn't know existed. Now I'm missing that terribly.)
- "16 bits, 48000 Hz (Dvd-quality)" max. Siriously guys? Where is at least the 24bit mode? It don't ask for a 192000Hz mode but 24bit at least.
- It seems that the loudest block in the frequency range gets boosted and all the quiet ranges get muted. Only turning of the dolby mode (the big power button) does prevent this. So it seems to be an issues in the dolby driver? (This could produce the dull/muffled sound addressed above.)

Anyways, I've returned to the previous driver cause this just made it worse and made me unable to produce any music.
So I've found an additional bug while using Skype today. There is a constant bass traveling through my mic and I can even hear it through my headphones.
Reply With Quote


  #47  
Old 03-29-2013, 06:24 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 643746
RAM GUY Reputation: 10
Default

Thanks everyone for reporting the issue. We are working on a fix for this and have taken down the Vengeance 1500 drivers temporarily.

For anyone experiencing the "crackling", please go into your equalizer and lower each setting by 6db. Please report back once you have done so (following my format) and let me know if it works. Please also include what headset you have so I can track it.
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


  #48  
Old 03-29-2013, 07:22 PM
shankly1985 shankly1985 is offline
Registered User
shankly1985's PC Specs
 
Join Date: Nov 2012
Posts: 145
POST ID # = 643756
shankly1985 Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
Thanks everyone for reporting the issue. We are working on a fix for this and have taken down the Vengeance 1500 drivers temporarily.

For anyone experiencing the "crackling", please go into your equalizer and lower each setting by 6db. Please report back once you have done so (following my format) and let me know if it works. Please also include what headset you have so I can track it.
Hello RAMGuy I dont have any real issue so far but I do have one thing bugging me lol is it possible to have the Dolby option stay switched on after system reboot?
I keep needing to re-power the Dolby option.

Last edited by shankly1985; 03-29-2013 at 07:35 PM.
Reply With Quote


  #49  
Old 03-29-2013, 08:13 PM
NoahP NoahP is offline
PC Builder
NoahP's PC Specs
 
Join Date: Mar 2013
Location: United States
Posts: 21
POST ID # = 643759
NoahP Reputation: 10
Default

Pretty good ;)
Reply With Quote


  #50  
Old 03-29-2013, 09:30 PM
krneki krneki is offline
Registered User
 
Join Date: Sep 2012
Posts: 9
POST ID # = 643770
krneki Reputation: 10
Default

In games the situation, thanks to Dolby digital, has improved, even if in some remains bugged (in Bioshock Infinite you have to revert back to 2.0 to hear the voices in front of you), but in movies and music the sound quality is terrible, above all is the distorted bass.

I have a mixed feeling and wonder why the drivers have been released, since someone had to notice the problems.

Last edited by krneki; 03-29-2013 at 09:33 PM.
Reply With Quote


  #51  
Old 03-30-2013, 01:33 PM
Thunder350's Avatar
Thunder350 Thunder350 is offline
Registered User
Thunder350's PC Specs
 
Join Date: Jan 2011
Location: Maryland
Posts: 18
POST ID # = 643874
Thunder350 Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
Thanks everyone for reporting the issue. We are working on a fix for this and have taken down the Vengeance 1500 drivers temporarily.

For anyone experiencing the "crackling", please go into your equalizer and lower each setting by 6db. Please report back once you have done so (following my format) and let me know if it works. Please also include what headset you have so I can track it.
Thanks for the update, glad to hear a fix is being worked on! Lowering the settings does help some, but the issues still persist, they're just not as bad. - Vengeance 1500.
Reply With Quote


  #52  
Old 03-30-2013, 02:32 PM
murderklok murderklok is offline
Registered User
 
Join Date: Mar 2013
Posts: 4
POST ID # = 643882
murderklok Reputation: 10
Default

Went back to the old drivers for 24/96000hz. Can't stand 16/48000hz limitation.
Reply With Quote


  #53  
Old 03-30-2013, 04:53 PM
echosky echosky is offline
Registered User
 
Join Date: Nov 2012
Posts: 17
POST ID # = 643901
echosky Reputation: 10
Default

So what's corsair doing with all this money they're making? Their Quality Control has some serious issues.... I've had issues with my 400R case, H100i Pump, and the famous cracked headset for the Vengeance 2000.... and now drivers that do more bad than good. Recent experiences have not been good.
Reply With Quote


  #54  
Old 03-30-2013, 08:39 PM
Slowari Slowari is offline
Registered User
 
Join Date: Mar 2013
Posts: 3
POST ID # = 643924
Slowari Reputation: 10
Default

Quote:
Originally Posted by murderklok View Post
Went back to the old drivers for 24/96000hz. Can't stand 16/48000hz limitation.
That limitation is allways been there HW does support 16/48000Hz at max.

"DAC sampling rate from 8Khz, 16Khz, 44.1Khz to 48Khz, 16-bit resolution"

http://www.cmedia.com.tw/ProductsDet...no=26&PSerno=9
Reply With Quote


  #55  
Old 03-31-2013, 12:39 AM
murderklok murderklok is offline
Registered User
 
Join Date: Mar 2013
Posts: 4
POST ID # = 643954
murderklok Reputation: 10
Default

That may be but it sounds considerably worse.
Reply With Quote


  #56  
Old 03-31-2013, 06:01 AM
Azze Azze is offline
Registered User
 
Join Date: Mar 2013
Posts: 8
POST ID # = 643978
Azze Reputation: 10
Default

When i restart my computer the new corsair headset control panel doesn't remember my EQ settings. I can see my profile selected there all well and good but it sounds like default EQ, untill i play some music and swap EQ profiles around a bit. It gets rather anoying to do suchs process on every boot up.
Reply With Quote


  #57  
Old 03-31-2013, 07:30 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 643992
Toasted Toasted Reputation: 108
Default

Did you save the profile by clicking the + button?
Reply With Quote


  #58  
Old 03-31-2013, 02:32 PM
Azze Azze is offline
Registered User
 
Join Date: Mar 2013
Posts: 8
POST ID # = 644053
Azze Reputation: 10
Default

Quote:
Originally Posted by Toasted View Post
Did you save the profile by clicking the + button?
Ofcourse.
How else could i see my profile selected?
Reply With Quote


  #59  
Old 03-31-2013, 07:14 PM
TylerAD TylerAD is offline
Registered User
TylerAD's PC Specs
 
Join Date: Mar 2013
Posts: 69
POST ID # = 644098
TylerAD Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
Thanks everyone for reporting the issue. We are working on a fix for this and have taken down the Vengeance 1500 drivers temporarily.

For anyone experiencing the "crackling", please go into your equalizer and lower each setting by 6db. Please report back once you have done so (following my format) and let me know if it works. Please also include what headset you have so I can track it.
Yes, the - 6 on all the channels seems to work for me. Will be testing out in game soon, thanks! 1500v win7 x64
Reply With Quote


  #60  
Old 03-31-2013, 11:38 PM
TylerAD TylerAD is offline
Registered User
TylerAD's PC Specs
 
Join Date: Mar 2013
Posts: 69
POST ID # = 644127
TylerAD Reputation: 10
Default

New updated driver is better on sound, still very loud ( can only have it on like 4% in windows x64) The audio is still distorted even at -6 on the settings with the new drivers. The hiss is back in the microphone when i say "s" words. Its like i can here feed back from strong "s" words. 1500v , x64 win 7, windows settings on 7.1 ( can conform from audio play back) but settings are still off when it comes to sounds.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.