The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #16  
Old 12-20-2015, 03:57 PM
Mekc Mekc is offline
Registered User
 
Join Date: Nov 2015
Posts: 47
POST ID # = 826577
Mekc Reputation: 10
Default

Quote:
Originally Posted by waseland View Post
Turning sidetone off didn't do the trick. Lucky it worked for you! :)
Same, it did not help.
Reply With Quote


  #17  
Old 12-23-2015, 04:29 PM
gobentech's Avatar
gobentech gobentech is offline
gobentech
gobentech's PC Specs
 
Join Date: Nov 2015
Posts: 2
POST ID # = 827081
gobentech Reputation: 10
Default

Mine has been doing the same day since the first day. I pre-ordered it, so I've had it since the beginning. Nothing I have tried has made any difference, but I'm well beyond the return date.

I also have the problem with the microphone having a tinny/robotic/metallic sound which seems to happen randomly, but that's another matter entirely.
Reply With Quote


  #18  
Old 12-27-2015, 01:17 AM
Cetlysm Cetlysm is offline
Registered User
 
Join Date: Dec 2015
Posts: 10
POST ID # = 827664
Cetlysm Reputation: 10
Default

+1

How surprised was I when people told me my 4 years old $25 bucks Walmart Logitech headset on sale sounds WAY better than this brand new product.
Reply With Quote


  #19  
Old 03-26-2016, 07:04 AM
nitrousable nitrousable is offline
Registered User
 
Join Date: Mar 2016
Posts: 15
POST ID # = 844161
nitrousable Reputation: 10
Default

Same here.... I just got a USB version today
Reply With Quote


  #20  
Old 03-26-2016, 10:53 AM
nitrousable nitrousable is offline
Registered User
 
Join Date: Mar 2016
Posts: 15
POST ID # = 844185
nitrousable Reputation: 10
Default

The hissing seems to disappear if I turn off the Corsair Utility program. So what gives??
Reply With Quote


  #21  
Old 08-18-2017, 04:43 PM
brooks4812 brooks4812 is offline
Registered User
 
Join Date: Aug 2017
Posts: 1
POST ID # = 916706
brooks4812 Reputation: 10
Default Static in Left ear cup

I had this issue as well. It was in my left ear cup and would be noticeable at 20 and get louder as I increased the volume. I was playing around with my sound mixer and just by chance lowered my Realtek audio(microphone) volume. Poof!! The static went away completely. I would suggest opening your sound mixer and see if any of the Realtek audio devices are on. If they are, you can simply disable them. Hope this helps.
Reply With Quote


  #22  
Old 08-20-2017, 07:26 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,344
POST ID # = 916852
Toasted Toasted Reputation: 108
Default

Which VOID headset do you own? VOID USB/Wireless/Surround/Stereo?
Reply With Quote


  #23  
Old 10-21-2017, 07:01 AM
xDiiThy xDiiThy is offline
Registered User
xDiiThy's PC Specs
 
Join Date: Oct 2017
Posts: 5
POST ID # = 924010
xDiiThy Reputation: 10
Default

Just purchased the Void PRO RGB USB and Corsair has practically dumped support for this product, only problem is the left ear cup noise/static which is giving me a headache even when there is no audio playing as well as this threads issue of the normal static. So I have 2 static issues with this $150 AUD headset. WTF Corsair

Last edited by xDiiThy; 10-21-2017 at 07:09 AM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.