The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 08-15-2018, 11:04 AM
UncleDisco UncleDisco is offline
Registered User
UncleDisco's PC Specs
 
Join Date: Aug 2018
Posts: 3
POST ID # = 968666
UncleDisco Reputation: 10
Default HS70 loss of charge

Hi, I recently got myself a pair of HS70 and I'm loving them so far. However, it seems to lose a lot of charge when it's turned off. I turned it off last night with about 66% charge left, and today when I turned it back on (about 17 hours later) it was at 49%.

Is this normal?
Reply With Quote


  #2  
Old 08-15-2018, 03:29 PM
Corsair Mint's Avatar
Corsair Mint Corsair Mint is offline
Corsair Employee
 
Join Date: Apr 2016
Posts: 857
POST ID # = 968725
Corsair Mint Reputation: 31
Default

Hi UncleDisco, that is a bit of a drain when off. Can you see if cycling the battery (letting it fully drain then fully charge) helps sort of recalibrating the battery?
Reply With Quote


  #3  
Old 08-16-2018, 01:27 PM
UncleDisco UncleDisco is offline
Registered User
UncleDisco's PC Specs
 
Join Date: Aug 2018
Posts: 3
POST ID # = 968916
UncleDisco Reputation: 10
Default

So quick update. I have fully drained the battery and it is currently charging. One thing I did note is that charge did last about 16 hours total, which leads me to believe that it's some kind of software issue, with it not being able to display the correct charge.

In any case I will report back my results sometime tomorrow.
Reply With Quote


  #4  
Old 08-17-2018, 04:47 AM
UncleDisco UncleDisco is offline
Registered User
UncleDisco's PC Specs
 
Join Date: Aug 2018
Posts: 3
POST ID # = 969015
UncleDisco Reputation: 10
Default

So just turned it on this morning, and it has only lost about 3% during the night. So it's probably fine now. And since it lasted about 16 hours the last time around, it seems it never really did lose that charge to begin with, so it probably was the software reporting the charge incorrectly. Cycling the battery seems to have fixed it so, thanks!
Reply With Quote


  #5  
Old 08-17-2018, 03:49 PM
Corsair Mint's Avatar
Corsair Mint Corsair Mint is offline
Corsair Employee
 
Join Date: Apr 2016
Posts: 857
POST ID # = 969110
Corsair Mint Reputation: 31
Default

Great! Good to hear!
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.