The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 12-05-2019, 10:50 PM
DarkShadix DarkShadix is offline
Registered User
 
Join Date: Dec 2019
Posts: 1
POST ID # = 1026487
DarkShadix Reputation: 10
Default Harpoon RGB Wireless not working

I was wondering if I was missing anything. I downloaded the iCUE software and updated the mouse and dongle but the slipstream feature refuses to work correctly. My computer recognizes the dongle. Using Bluetooth and the wire work perfectly fine it's just the slipstream technology that's being unresponsive. The only way I can get it to "work" is if I force an update while the dongle and the mouse are plugged in then unplug the wire, but once I turn the mouse off it will not reconnect unless I do that again. When I click "USB Wireless receiver pairing" it says it was successful but as soon as I unplug the wire it disconnects and acts as if the mouse is off even when I get it to "work". I just got this mouse as a replacement for my old wireless mouse and I even put the dongle in the same spot as the old one since it worked just fine there. Do I just have to buy a new one? I don't know what to do with it since the main reason I bought the thing doesn't even work. I ordered it off of Best Buy online but I didn't get a warranty because I didn't expect this to happen, just in case that info would be useful.
Reply With Quote


  #2  
Old 12-05-2019, 11:55 PM
DevBiker's Avatar
DevBiker DevBiker is offline
CORSAIR Beta Team
DevBiker's PC Specs
 
Join Date: Feb 2017
Location: Republic of Texas
Posts: 8,155
POST ID # = 1026490
DevBiker Reputation: 94
Default

At this point, I could open a ticket with Corsair Support.
__________________
Please click "Edit System Specs" and fill out your system info.

This comment is provided "as-is", without warranty of any kind, express or implied, including, but not limited to, the sanity or mental fitness of the author. The author is not a Corsair employee, does not represent Corsair, and no comment should be construed as an official statement from Corsair.

Helpful Links and FAQs:
AIO FAQ | RGB FAQ |
HydroX FAQ | RGB Cables |
iCUE Tips & Tricks

Reply With Quote


  #3  
Old 12-06-2019, 05:00 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 681
POST ID # = 1026553
Apophis3 Reputation: 12
Default

Try reflashing it, the dongle may have bummed during the last one. And please, make sure you follow the instructions given by iCUE. The flashing process for my Ironclaw is different from my Dark Core for example.
Reply With Quote


  #4  
Old 12-12-2019, 11:02 PM
W01F51 W01F51 is offline
Registered User
 
Join Date: Oct 2019
Posts: 10
POST ID # = 1027302
W01F51 Reputation: 10
Default

Where can I find how to reflash it?
Reply With Quote


  #5  
Old 12-13-2019, 12:49 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 681
POST ID # = 1027358
Apophis3 Reputation: 12
Default

Under Settings, you hit Update Firmware, and it'll ask if you would like to Force an Update, say yes, and follow prompts
Reply With Quote


  #6  
Old 12-14-2019, 01:53 AM
W01F51 W01F51 is offline
Registered User
 
Join Date: Oct 2019
Posts: 10
POST ID # = 1027430
W01F51 Reputation: 10
Default

Oh, whenever I put a new part in my computer the wireless reciever to my mouse stops working. I tried to reflash it, but the wireless reciever wasn't recognized by my computer.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.