The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 12-17-2014, 08:21 AM
bntlol bntlol is offline
Registered User
 
Join Date: Dec 2014
Posts: 2
POST ID # = 747408
bntlol Reputation: 10
Default H2100 keeps loosing connection

Hi.

My h2100 has been working OK for a couple of weeks now, it has dropped connection like 1-5 times a day, which was annoying, but still managable.

Since yesterday, the headset has lost connection atleast 50 times, ive restarted my PC, changed USB-port on the dongle, restarted the headset, drained the headset and recharged it, and also tried it on another computer. It'll work flawless sometimes for 10-15 minutes, and then struggle to stay connected for 10-15 minutes, this goes in waves, more or less.

I havent added or removed ANY wireless devices, or other electronical devices, everything in my apartment is exactly the same as when it worked fine, but now it's just toying with me. I'm really disappointed, im leaving to go to USA for 3 weeks tomorrow, and i dont have time to turn it in to the store before i leave. Any tips, workarounds, or things i can try to fix this? It's reaaally annoying :(

Thanks!
Reply With Quote


 

Tags
connection, dongle, h2100, problem, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.