The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 18 votes, 4.94 average. Display Modes
  #1  
Old 12-19-2011, 11:26 AM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 548988
tgdragos Reputation: 10
Angry Problem with my M60 under EFI BIOS

...and i realy hope you guys(Corsair) will help me solve it.

I just bought the damn mouse , 45 minutes ago.

The mouse moves ONLY horizontally in the middle of the screen under Bios. That's It.( i dont know if Rclick or LClick work or if the scroll works, i can't point it to somewhere that would allow me to test clicks and scroll.)

I tinker with my bios very offten. This is one of the reasons i bought an EFI board.
So i am a little frustrated. I do my things now on keyboard only.
Needless to say i didn't had any issues with my microsoft optical usb mouse.

I didn't installed the drivers under Windows either. I have no issues under Windows, i hope it's stays this way.


Thanks.
Reply With Quote


  #2  
Old 12-19-2011, 01:26 PM
fvbounty fvbounty is offline
Registered User
fvbounty's PC Specs
 
Join Date: Jun 2002
Posts: 216
POST ID # = 549012
fvbounty Reputation: 10
Default

Once I read your post I tried my M60 on my Asus P8Z68 Deluxe Gen 3 motherboard and your right it doesn't work in my EFI bios either just goes left and right. My K90 keyboard did let me into the bios and I had to hit F10 to get into the advanced mode so I could move around in advanced mode and exit. Not good!
Reply With Quote


  #3  
Old 12-20-2011, 12:17 PM
AlexRiker AlexRiker is offline
Registered User
AlexRiker's PC Specs
 
Join Date: Nov 2011
Posts: 28
POST ID # = 549231
AlexRiker Reputation: 10
Default

tgdragos- what is your motherboard?. Also not that this solves this issue, but in every bios I've ever used it is possible to fully navigate and configure it using the keyboard alone (the arrow keys, enter, and such), so at least this isn't as annoying as having the keyboard not work.
Reply With Quote


  #4  
Old 12-20-2011, 01:59 PM
JustinHEMI JustinHEMI is offline
Registered User
JustinHEMI's PC Specs
 
Join Date: Apr 2008
Location: PA
Posts: 158
POST ID # = 549251
JustinHEMI Reputation: 10
Default

Do you have legacy USB enabled? If not, might be worth a shot.
Reply With Quote


  #5  
Old 12-20-2011, 02:53 PM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 549261
tgdragos Reputation: 10
Default

Quote:
Originally Posted by AlexRiker View Post
tgdragos- what is your motherboard?. Also not that this solves this issue, but in every bios I've ever used it is possible to fully navigate and configure it using the keyboard alone (the arrow keys, enter, and such), so at least this isn't as annoying as having the keyboard not work.
Yes, the keyboard works, but still...i would like the mouse to work also.
For my is a big deal, as I tinker very often with my bios.

My mobo:Asus Maximus IV Extreme (P67)
Reply With Quote


  #6  
Old 12-20-2011, 04:30 PM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 549277
tgdragos Reputation: 10
Default

Quote:
Originally Posted by JustinHEMI View Post
Do you have legacy USB enabled? If not, might be worth a shot.
Yes,it is enabled. Dosen't work.
Reply With Quote


  #7  
Old 12-20-2011, 11:58 PM
persentio persentio is offline
Obscurus
persentio's PC Specs
 
Join Date: Mar 2011
Posts: 260
POST ID # = 549366
persentio Reputation: 10
Default

Correct me if I'm wrong, but AFAIK ALL sorts of 'advanced' mice tend to have problems in UEFI BIOSes, and the onus is actually on the UEFI BIOS developers to support these mice.

My Razer mouse had its axes inverted in Asrock's UEFI bios. However, after feedback they actually released an update for its UEFI BIOS that corrected the problem.
Reply With Quote


  #8  
Old 12-21-2011, 04:15 AM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 549388
tgdragos Reputation: 10
Default

Quote:
Originally Posted by persentio View Post
Correct me if I'm wrong, but AFAIK ALL sorts of 'advanced' mice tend to have problems in UEFI BIOSes, and the onus is actually on the UEFI BIOS developers to support these mice.

My Razer mouse had its axes inverted in Asrock's UEFI bios. However, after feedback they actually released an update for its UEFI BIOS that corrected the problem.
You are probably right.
But i'm not sure, as a "consumer" ,that is my job to ensure compatibility between the mouse and Efi bioses by babbling to forums until someone decides to make an update or something. I for sure can not determine Asus to release a bios update because my M60 dosen't work.
But maybe Corsair can. And they should have taken the necesary action to ensure EFi BIOS compatibility upon releasing a mouse. Or at least for popular boards.
EFI BIOSes are very popular right now and I belive to be the new standard so this should have been on their agenda.

My disappointment is that Corsair didn't take the necessary actions( corporate to corporate, or i don't know how this work) to ensure compatibility. And i was not informed that there is an incompatibility between the mouse and, in my case, Asus Maximus IV Extreme Efi Bios
If I knew that and still bought the mouse , then it would have been my decision not to care about this issue.

Last edited by tgdragos; 12-21-2011 at 04:16 AM. Reason: grammar!
Reply With Quote


  #9  
Old 12-23-2011, 02:13 AM
AlexRiker AlexRiker is offline
Registered User
AlexRiker's PC Specs
 
Join Date: Nov 2011
Posts: 28
POST ID # = 549884
AlexRiker Reputation: 10
Default

I understand your frustration, however I think corsair is as powerless to fix it as we are- there are a ton of motherboards, ensuring compatibility with 'popular' ones is simply unrealistic, and every other vendor also has this problem. My g500 from logitech didn't work in my bios until MSI released several updates.

It's just one of those things- it would be nice if they mentioned potential uefi compat issues in FAQ, but it's not a problem isolated to corsair, and it's not a problem that any other company has come up with a superior solution for.
Reply With Quote


  #10  
Old 12-23-2011, 04:29 AM
s74r1 s74r1 is offline
Registered User
 
Join Date: Dec 2011
Posts: 57
POST ID # = 549900
s74r1 Reputation: 10
Default

Quote:
Originally Posted by persentio View Post
Correct me if I'm wrong, but AFAIK ALL sorts of 'advanced' mice tend to have problems in UEFI BIOSes, and the onus is actually on the UEFI BIOS developers to support these mice.
my Logitech G700 is quite "advanced" and it has no problems in UEFI bios's like the M90 or Razer.

I'll have to test the bios on my Asus Maximus IV Gene-Z to see if I get this problem too though
Reply With Quote


  #11  
Old 12-23-2011, 03:39 PM
RAM GUY's Avatar
RAM GUY RAM GUY is offline
Corsair Product Guru
 
Join Date: Apr 2001
Location: Fremont, CA
Posts: 118,268
POST ID # = 549974
RAM GUY Reputation: 10
Default

I was sent an email from the Product manager who has been working with the Engineering team on this and this was their reply:
Quote:
BIOS issue, solution update BIOS, doesn’t enumerate OK mouse for having 16bit data for X/Y axis, expects mouse with 8bit data for X/Y axis.

“We have followed up in troubleshooting this issue and it will be resolved if you update your motherboard BIOS. If you have any additional issues, please contact us at Corsair.”
__________________
Support accounts and tickets can be created at https://support.corsair.com.
Reply With Quote


  #12  
Old 12-23-2011, 05:40 PM
fvbounty fvbounty is offline
Registered User
fvbounty's PC Specs
 
Join Date: Jun 2002
Posts: 216
POST ID # = 549992
fvbounty Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
I was sent an email from the Product manager who has been working with the Engineering team on this and this was their reply:
Well I have latest bios on my Asus P8Z68 Deluxe Gen 3, so I guess I wait until Asus comes out with a updated bios to fix this?
Reply With Quote


  #13  
Old 12-23-2011, 11:27 PM
Mergatroid Mergatroid is offline
Registered User
Mergatroid's PC Specs
 
Join Date: Jan 2011
Posts: 44
POST ID # = 550095
Mergatroid Reputation: 10
Default

I was using a RAT9 and it also did not work properly in my BIOS even though my Logitech G9x does. I haven't tested the M90 yet. Keeping my fingers crossed.

The same thing would happen in my backup software if I boot from it to image the system. RAT9 wouldn't work while G9X did. Feels like the 80s all over again.
Reply With Quote


  #14  
Old 12-24-2011, 02:12 PM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 550158
tgdragos Reputation: 10
Default

Quote:
Originally Posted by RAM GUY View Post
I was sent an email from the Product manager who has been working with the Engineering team on this and this was their reply:
I already have the latest bios version : Version 2105 from 2011.12.14 .

So i guess i have to wait for another version?
Reply With Quote


  #15  
Old 01-13-2012, 06:02 AM
tgdragos tgdragos is offline
Registered User
tgdragos's PC Specs
 
Join Date: May 2011
Posts: 16
POST ID # = 554424
tgdragos Reputation: 10
Default

...to much drama with this mouse. I never installed any software either.
I couldn't find a single thread with more positive reviews then negative ones.

As for my issue ,what now seems to be small (compared with the others),i decided to buy another gaming mouse. Couldn't be happier. Same laser sensor, top notch software, works in my bios. even if it is ambidextrous it fits and feels good.
I like Corsair i have many of their products, and my intention was to have a paired KB+Mouse from Corsair.This will not be possible for me. I don't like the KBs for many reasons already all over the forum. I hope their next line of HID devices will, be better.

Curenlty my M60 remains a beautiful presse-papier :


http://imageshack.us/photo/my-images/834/13012012.jpg/
Reply With Quote


Reply

Tags
bios, efi, m60

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.