The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-16-2014, 05:55 PM
EpicPotatoYT EpicPotatoYT is offline
Registered User
EpicPotatoYT's PC Specs
 
Join Date: Dec 2013
Location: Denmark
Posts: 3
POST ID # = 692947
EpicPotatoYT Reputation: 10
Exclamation Corsair Vengeance 2000 Charging Issue(s)

Hi Corsair,

Lately (Started yesterday) I have had issues charging the headset, I had to precisely position the headset and the charging cord to charge it. I have tried other cables with the same issue. When I finally get it to the right position I can't wear it on my head because that would disturb the placement of the headset and therefore it wouldn't charge. (Basically, I had to use 5 minutes to get it charging and I couldn't use it while charging because it had to lie still.)

There's also a different issue; If I connect a charging cord (any) my headset will randomly disconnect from the PC, rendering it not usable while charging,


These two issues are really weird and I can't use the headset as I said, while it's trying to charge. I hope we can sort this out because I really love your products


-Potato
Reply With Quote


  #2  
Old 01-17-2014, 01:44 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,331
POST ID # = 693007
Toasted Toasted Reputation: 124
Default

Have you tried a different charging cable(MicroUSB)? Does it do the same thing?

If it does, it sounds like there is a problem with the charging port. Request an RMA to replace the headset. Also upload a picture of your invoice to the ticket as well.
Reply With Quote


  #3  
Old 01-17-2014, 03:29 AM
EpicPotatoYT EpicPotatoYT is offline
Registered User
EpicPotatoYT's PC Specs
 
Join Date: Dec 2013
Location: Denmark
Posts: 3
POST ID # = 693034
EpicPotatoYT Reputation: 10
Default

It does do the same thing with different cables, looks like I have to request a RMA..

Thanks for the reply!


-Potato
Reply With Quote


Reply

Tags
charge, disconnection, usb bug

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.