The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Audio

Notices

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 01-16-2014, 09:40 AM
Splatch Splatch is offline
Registered User
 
Join Date: Jan 2014
Posts: 2
POST ID # = 692876
Splatch Reputation: 10
Default Vengeance 2100 power button dont work

Hi everybody, i bought some weeks ago this awesome wireless headset, i was really happy to have it and he was working really well.

Then fews days after that, and a night on my desk, the headset power button wasnt working, when i can see the headset himself seems to have battery (because the light on the usb part was working) i can't make the headset go ON. Well some minute after that (when i unplug the usb on it) the headset was sudently working, but one week later this problem occur again, and i really dont know why, or how i can make in work.. If it has a "reset" option, a "freeze" option idk. I hope someone will have a answer to that, thanks in advance, all my faith is on you guys !

(Sorry for my english, it's not my 1st language :s & an happy new year to everyone ! )

Last edited by Splatch; 01-16-2014 at 09:42 AM.
Reply With Quote


  #2  
Old 01-17-2014, 01:42 AM
Toasted Toasted is offline
Registered User
 
Join Date: Apr 2011
Posts: 19,331
POST ID # = 693006
Toasted Toasted Reputation: 124
Default

Does this only happen when the charging cable is plugged in?
Reply With Quote


  #3  
Old 01-17-2014, 06:16 PM
Splatch Splatch is offline
Registered User
 
Join Date: Jan 2014
Posts: 2
POST ID # = 693138
Splatch Reputation: 10
Default

It happen when i turn of my computer with the headset with the cable plugged in.

He is working now, after like 30min of charging.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.