The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Corsair Link

Closed Thread
 
Thread Tools Search this Thread Rate Thread Display Modes
  #31  
Old 10-02-2017, 10:10 PM
Speedbreaker12 Speedbreaker12 is offline
Registered User
Speedbreaker12's PC Specs
 
Join Date: Aug 2017
Posts: 18
POST ID # = 921955
Speedbreaker12 Reputation: 17
Default

Link 4.9.0.57 only shows 16 of my 18 cores, is there a way to fix that?

CPU.JPG


  #32  
Old 10-02-2017, 11:25 PM
dcb147's Avatar
dcb147 dcb147 is offline
Registered User
dcb147's PC Specs
 
Join Date: Oct 2017
Location: New Orleans, LA
Posts: 1
POST ID # = 921964
dcb147 Reputation: 10
Default

Link v4.9.0.57
Unsigned Driver issue
Shows up as a not working device in Device Manager, USB Bus Controllers: Corsair USBXp Driver
Driver Properties shows error code 52
Problem is NOT intermittent
My Corsair H80iGT is not found by Link software
Have uninstall/re-install driver and Link software several times using different methods
Tried going back to earlier Link software, but the problem would not go away even with Link software v4.8.2.1 that was working on previous installation of Windows.
This is a new, clean install of Windows 10 Pro, Version 1703, Build 15063.632, up-to-date on updates, therefore I do not have much to add.
This was the first thing I tried installing after re-installing Windows. A very clean system.
No antivirus or malware, other than Windows Defender right now. (That will change to Norton soon.)

Last edited by dcb147; 10-02-2017 at 11:43 PM.


  #33  
Old 10-03-2017, 10:46 AM
pip_jones pip_jones is offline
Registered User
pip_jones's PC Specs
 
Join Date: Jul 2011
Posts: 108
POST ID # = 922028
pip_jones Reputation: 31
Default @Corsair, please join in the "discussion"

Quote:
Originally Posted by pip_jones View Post

BUMP.

You've asked us to discuss, but, you're not joining the discussion.


1 members found this post helpful.
  #34  
Old 10-03-2017, 01:53 PM
mariojuniorjp's Avatar
mariojuniorjp mariojuniorjp is offline
Registered User
mariojuniorjp's PC Specs
 
Join Date: Oct 2017
Posts: 2
POST ID # = 922057
mariojuniorjp Reputation: 10
Default

Quote:
Originally Posted by dcb147 View Post
Link v4.9.0.57
Unsigned Driver issue
Shows up as a not working device in Device Manager, USB Bus Controllers: Corsair USBXp Driver
Driver Properties shows error code 52
Problem is NOT intermittent
My Corsair H80iGT is not found by Link software
Have uninstall/re-install driver and Link software several times using different methods
Tried going back to earlier Link software, but the problem would not go away even with Link software v4.8.2.1 that was working on previous installation of Windows.
This is a new, clean install of Windows 10 Pro, Version 1703, Build 15063.632, up-to-date on updates, therefore I do not have much to add.
This was the first thing I tried installing after re-installing Windows. A very clean system.
No antivirus or malware, other than Windows Defender right now. (That will change to Norton soon.)
Same problem here on the same Windows version, with my H80i v2. Every goddamn release is the same problem. Why Corsair does not fix the damn driver signing?

It is ridiculous to buy a product and not be able to use it in its full capacity, because the manufacturer itself cannot even offer a damn driver that works.

EDIT: This guy has reported this "error 52" several times, but corsair simply does not correct it: http://forum.corsair.com/v3/showpost...87&postcount=2

EDIT 2: now where's my goddamn fan?


Last edited by mariojuniorjp; 10-03-2017 at 02:33 PM.


  #35  
Old 10-04-2017, 06:01 PM
SpeedyV SpeedyV is offline
Registered User
SpeedyV's PC Specs
 
Join Date: Jan 2017
Posts: 419
POST ID # = 922210
SpeedyV Reputation: 41
Default Link is limited to 16 cores

Quote:
Originally Posted by Speedbreaker12 View Post
Link 4.9.0.57 only shows 16 of my 18 cores, is there a way to fix that?

Attachment 31299
Corsair Link is a 32-bit program. It is thus limited to reading 16 cores. To read more that 16 cores, Link would need to be rewritten as a 64-bit application. I have no idea if Corsair plans to upgrade Link to be a 64-bit application. With the advent of >16 core HEDT CPUs, I hope so.

If you are interested, SIV, being 64-bit, can read all of your cores. The author of SIV is not on the Corsair forum anymore to guide you (SIV can be a bit overwhelming at first glance) but you can check out his site.

http://rh-software.com/

Good Luck!


  #36  
Old 10-05-2017, 03:12 AM
rangka_kacang rangka_kacang is offline
Registered User
 
Join Date: Sep 2017
Posts: 12
POST ID # = 922228
rangka_kacang Reputation: 10
Default

Quote:
Originally Posted by mariojuniorjp View Post
Same problem here on the same Windows version, with my H80i v2. Every goddamn release is the same problem. Why Corsair does not fix the damn driver signing?

It is ridiculous to buy a product and not be able to use it in its full capacity, because the manufacturer itself cannot even offer a damn driver that works.

EDIT: This guy has reported this "error 52" several times, but corsair simply does not correct it: http://forum.corsair.com/v3/showpost...87&postcount=2

EDIT 2: now where's my goddamn fan?

I feel you and I get why you are piss, so do I but the good news is, Corsair Dustin replied to this thread saying an upcoming version that has this fix implemented, currently pending internal validation:

http://forum.corsair.com/v3/showpost...3&postcount=46

I'm using H115i and have the same problem like you do. I agreed on the 64-bit replied too. Corsair need to hire (a) more competent software developer(s). Without a good driver, a top-notch hardware is pretty much useless for now, I'm using 4.7.0.77 as a temporary solution. You can check out my screenshot on this post:

http://forum.corsair.com/v3/showpost...7&postcount=43


  #37  
Old 10-05-2017, 06:14 AM
numb numb is offline
Registered User
 
Join Date: May 2016
Posts: 15
POST ID # = 922235
numb Reputation: 10
Default

error code 52? please help me! i have a problem with a Digital Signature.



CorsairLink 4.9.0.57 Reinstalling New Version and Old version! same result.
Clear Registry Using CCleaner.
Uninstall the Driver from Device Manager.

Windows 10 Home 1703
Build 15063.632


  #38  
Old 10-05-2017, 08:02 AM
SpeedyV SpeedyV is offline
Registered User
SpeedyV's PC Specs
 
Join Date: Jan 2017
Posts: 419
POST ID # = 922244
SpeedyV Reputation: 41
Default

Quote:
Originally Posted by numb View Post
error code 52? please help me! i have a problem with a Digital Signature.



CorsairLink 4.9.0.57 Reinstalling New Version and Old version! same result.
Clear Registry Using CCleaner.
Uninstall the Driver from Device Manager.

Windows 10 Home 1703
Build 15063.632
You need to roll back to an earlier version of Link that has properly signed Drivers. See http://forum.corsair.com/forums/show...115#post922115

http://forum.corsair.com/forums/show...65&postcount=2

And the thread below this one.


  #39  
Old 10-05-2017, 09:34 AM
numb numb is offline
Registered User
 
Join Date: May 2016
Posts: 15
POST ID # = 922253
numb Reputation: 10
Default

Quote:
Originally Posted by SpeedyV View Post
You need to roll back to an earlier version of Link that has properly signed Drivers. See http://forum.corsair.com/forums/show...115#post922115

http://forum.corsair.com/forums/show...65&postcount=2

And the thread below this one.
thanks bro! my H80i GT its working now! imanualy install the drivers. my only problem now is my psu ax860i. i already testing the drivers from that forum. but no luck!

Edit* thanks alot guys! problem solved!

Last edited by numb; 10-05-2017 at 12:53 PM.


  #40  
Old 10-05-2017, 01:56 PM
hutt132 hutt132 is offline
Registered User
 
Join Date: Sep 2013
Posts: 14
POST ID # = 922288
hutt132 Reputation: 10
Default

Windows 10 Version 10.0.14393 Build 14393
Corsair Link v4.9.0.57

DPC Latency before and after Corsair Link is running:
http://puu.sh/xQgJO/bd1d0ac30d.png

As shown in the image above, DPC latency is very high when Corsair Link is running (4000us). Once I close Corsair Link by clicking Exit in my tray, the DPC latency goes back to normal (500us).

This high DPC latency is causing my audio to pop when playing music and is very frustrating. If it isn't fixed soon, I'm going to have to find something else to control my fans. I saw a few threads in the past where this issue was fixed with an update, but it seems to have be happening again. Could a developer please look into this and patch the issue?


  #41  
Old 10-05-2017, 05:01 PM
klosz007 klosz007 is offline
klosz007
klosz007's PC Specs
 
Join Date: Aug 2014
Location: Poland
Posts: 4
POST ID # = 922308
klosz007 Reputation: 10
Default

Hi,

The reason why some people have issues with these unsigned drivers in CL 4.9 and some don't reminded me of similar case with Dism.sys driver included with latest Windows 10 ADK build for Creators Update. Own Microsoft driver isn't signed there too (yes !!!) but the issue presents itself only when PC has Secure Boot (SB) enabled. If SB is disabled then Dism.sys driver delivered with latest ADK loads with no issues.

I wasn't testing this myself with CL 4.9 (yet) but maybe someone can try if lates UsbXP driver loads fine when SB is disabled in UEFI.

BR,
Zbyszek


  #42  
Old 10-05-2017, 05:11 PM
SpeedyV SpeedyV is offline
Registered User
SpeedyV's PC Specs
 
Join Date: Jan 2017
Posts: 419
POST ID # = 922311
SpeedyV Reputation: 41
Default

Quote:
Originally Posted by klosz007 View Post
Hi,

The reason why some people have issues with these unsigned drivers in CL 4.9 and some don't reminded me of similar case with Dism.sys driver included with latest Windows 10 ADK build for Creators Update. Own Microsoft driver isn't signed there too (yes !!!) but the issue presents itself only when PC has Secure Boot (SB) enabled. If SB is disabled then Dism.sys driver delivered with latest ADK loads with no issues.

I wasn't testing this myself with CL 4.9 (yet) but maybe someone can try if lates UsbXP driver loads fine when SB is disabled in UEFI.

BR,
Zbyszek
You can also disable Driver Signature Enforcement which Corsair has recommended to do in the past. Some are OK with this and others are not. The Driver Signing Enforcement is there for a reason. Defeating this safety mechanism to make Corsair's problem go away is a personal choice. If you decide to take that path, just Google "Driver Signature Enforcement" and you will find the procedure for disabling it.

I guess disabling Secure Boot may also work. Worth a try. Most people are just regressing back to an earlier version of Link and loading those drivers, which work properly. The links to regression files are in the sticky post under this thread.

Good Luck!


  #43  
Old 10-05-2017, 05:37 PM
klosz007 klosz007 is offline
klosz007
klosz007's PC Specs
 
Join Date: Aug 2014
Location: Poland
Posts: 4
POST ID # = 922313
klosz007 Reputation: 10
Default

Surely, both solutions are only workarounds, but disabling SB (assuming that it really helps with UsbXp) is less insecure than disabling driver signing. Many may have already disabled SB to dual boot alternative OSes like Linux.
Like with downgradinng UsbXp driver, there's similar solution for ADK too (replacing Dism.sys driver with the one delivered with Windows 10 CU itself) but nevertheless Corsair (and Microsoft) should fix it in the long run.

I just wanted to emphasize that Microsoft makes similar mistakes too (which doesn't justify Corsair at all) and similar solution might help for CL.


  #44  
Old 10-06-2017, 08:43 PM
Speedbreaker12 Speedbreaker12 is offline
Registered User
Speedbreaker12's PC Specs
 
Join Date: Aug 2017
Posts: 18
POST ID # = 922440
Speedbreaker12 Reputation: 17
Default

Hey guys,

so I was running some benchmarks on my I9-7980XE and because I obviously watched some videos before I bought the cpu, I knew what to expect.

Unfortunately my scores were way lower than the one of similar overclocked cpus in benchmarks. I spend about 2 days updating drivers, checking bios settings again and again.

Until I had the idea to close Corsair Link AND BAMM my performance went through the roof as expected. As an example from 3720 in Cinebench to 4050!

HOW is that even possible?!? Corsair link should only control my fans and play some fancy light animations and not take away like 15% of my performance!

Is there a way to fix this?? I had known that before building my system, I had thrown all of the RGB stuff out! Seriously, it's not worth to lose 15% performance on my 7500$ Rig for some blinking lights! I hope this can be fixed in a future update!


  #45  
Old 10-08-2017, 04:27 PM
duckbit1 duckbit1 is offline
Registered User
duckbit1's PC Specs
 
Join Date: Oct 2017
Posts: 1
POST ID # = 922646
duckbit1 Reputation: 10
Default H80i v2 not showing in Link 4 and code 52

1. Link version - v4.9.0.57
2. Windows 10 Home 64 bit.
3. I have an error code 52 in device manager and my cooler isn't showing in link.
4. I have noticed that I cannot edit the profile of the cooler at all as it does not show in link or in the device manager, I have tried uninstalling, reinstalling, updating drivers, the whole lot. I contacted Microsoft but they were as useless as ever.


Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.