The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #1  
Old 07-10-2019, 03:37 PM
OverCluster OverCluster is offline
Registered User
OverCluster's PC Specs
 
Join Date: Apr 2019
Posts: 8
POST ID # = 1010798
OverCluster Reputation: 10
Default Corsair Ironclaw RGB lose connection

Hi,

I'm currently using a Corsair Ironclaw RGB mouse. The thing is, the mouse disconnects when using vía 2.4Ghz connection.

When I turn it on, it won't move the cursor. Sometimes I fix it by unplugging the USB Dongle in the front USB 2.0 port, and other times i just have with the wired.

I wanted to know if there is a specific method to resincrhonize again. I know that pressing one or more keys the mouse starts searching for the USB Dongle.

Thanks so much,
Reply With Quote


  #2  
Old 07-10-2019, 05:16 PM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,414
POST ID # = 1010808
c-attack c-attack Reputation: 107
Default

I had a short bout with this when it first came out, but that was a few iCUE versions ago. It would loose the connection on wake from sleep. A quick re-plug of the USB dongle was the fastest resolution and the problem went away and has not returned.

Which iCUE version are you using? Is there anything in particular that is triggering it? Or does it randomly drop while in use?
Reply With Quote


  #3  
Old 07-19-2019, 11:34 PM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 107
POST ID # = 1011853
Syberon Reputation: 12
Default

Quote:
Originally Posted by c-attack View Post
I had a short bout with this when it first came out, but that was a few iCUE versions ago. It would loose the connection on wake from sleep. A quick re-plug of the USB dongle was the fastest resolution and the problem went away and has not returned.

Which iCUE version are you using? Is there anything in particular that is triggering it? Or does it randomly drop while in use?
I also have this problem some time - my Ironclaw Wireless doesn't wake from sleep then PC wakes from sleep mode. Turning switch to "off - on" doesn't resolve this problem.

The resolution is to:
1. replug USB dongle
2. set PC to sleep mode again and wake it up

After re out of sleep mode the mouse starts to work. The problem only occurs then PC wakes from sleep. When mouse normally wakes it doesn't disconnects or other problems.

This problem occurs quite often. I'm using last versions of iCUE and firmware.

Last edited by Syberon; 07-19-2019 at 11:38 PM.
Reply With Quote


  #4  
Old 07-20-2019, 06:12 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,414
POST ID # = 1011869
c-attack c-attack Reputation: 107
Default

The wake from sleep problem was my issue as well and it was pretty much every single time. Went on for two weeks, stopped, and has never happened again. I don’t think I changed iCUE versions at that time, so I wonder if it is a Windows issue. I am on 1903 now and was then, but something clearly changed.
Reply With Quote


  #5  
Old 07-29-2019, 12:48 AM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 107
POST ID # = 1012939
Syberon Reputation: 12
Default

Quote:
Originally Posted by c-attack View Post
The wake from sleep problem was my issue as well and it was pretty much every single time. Went on for two weeks, stopped, and has never happened again. I don’t think I changed iCUE versions at that time, so I wonder if it is a Windows issue. I am on 1903 now and was then, but something clearly changed.
I have Windows 1903 and this issue is still occur. I think that problem is in dongle because switching mouse to "on - off - on" doesn't helps. Only replugging of dongle or set pc to sleep mode and wake it up again helps. I tried to use dongle with different USB ports (USB 2.0/3.0/3.1 what provided by different controllers on motherboard) but it doesn't helped.
Reply With Quote


  #6  
Old 10-03-2019, 05:45 PM
Maestro_ Maestro_ is offline
Registered User
 
Join Date: Oct 2019
Posts: 1
POST ID # = 1020142
Maestro_ Reputation: 10
Default Ironclaw Wireless RBG Not Working with 2.4 GHz

My Corsair ironclas wireless rbg doesn't work anymore over 2.4GHz. When connected to the cable it shows up in iCue as Ironclaw RGB Wireless (1) and when I also plugin the slipstream dongle and icon with the name Ironclaw RGB Wireless appears. However when only plugged in using the slipstream dongle the mouse will show up in iCue, but won't work at all.

Can someone help me to fix my issue?
Thanks in advance!
Reply With Quote


  #7  
Old 10-03-2019, 06:59 PM
Apophis3 Apophis3 is offline
Registered User
Apophis3's PC Specs
 
Join Date: Feb 2018
Posts: 627
POST ID # = 1020155
Apophis3 Reputation: 12
Default

Quote:
Originally Posted by Maestro_ View Post
My Corsair ironclas wireless rbg doesn't work anymore over 2.4GHz. When connected to the cable it shows up in iCue as Ironclaw RGB Wireless (1) and when I also plugin the slipstream dongle and icon with the name Ironclaw RGB Wireless appears. However when only plugged in using the slipstream dongle the mouse will show up in iCue, but won't work at all.

Can someone help me to fix my issue?
Thanks in advance!
Seems the iCUE device setup is a little wonky on your system. I suggest doing a repair install. If this doesn't fix it, then uninstall, and then manually remove leftover directories. (I don't have them off hand) Then install iCUE with the Slipstream dongle already installed.
Reply With Quote


  #8  
Old 10-05-2019, 10:19 AM
c-attack c-attack is offline
Registered User
c-attack's PC Specs
 
Join Date: Jun 2014
Posts: 9,414
POST ID # = 1020330
c-attack c-attack Reputation: 107
Default

After the most recent Windows updates, I started having this issue again as well and got locked out of 2.4 mode. Unlike before, unplugging and reconnecting the receiver did not work. To get going again, I connected another mouse, went into the Device Manager and uninstalled the Iron Claw Wireless and let it delete the driver. Restart the machine and plug the Iron Claw back in (wired mode). It should re-load the driver automatically. After iCUE is up and running, put the 2.4 receiver back in and switch over to wireless mode. Good so far, but it has only been a measly 24 hours.
Reply With Quote


  #9  
Old 10-05-2019, 10:45 AM
Syberon Syberon is offline
Registered User
Syberon's PC Specs
 
Join Date: May 2018
Location: Russia
Posts: 107
POST ID # = 1020340
Syberon Reputation: 12
Default

Quote:
Originally Posted by c-attack View Post
After the most recent Windows updates, I started having this issue again as well and got locked out of 2.4 mode. Unlike before, unplugging and reconnecting the receiver did not work. To get going again, I connected another mouse, went into the Device Manager and uninstalled the Iron Claw Wireless and let it delete the driver. Restart the machine and plug the Iron Claw back in (wired mode). It should re-load the driver automatically. After iCUE is up and running, put the 2.4 receiver back in and switch over to wireless mode. Good so far, but it has only been a measly 24 hours.
This problem didn’t disappeared for me and tormented me all the time with this mouse own. I opened a ticket in support and get RMAed my mouse, but the problem doesn't disappeared on new mouse that i received from Corsair service. And now support stuff saying to me that they can't repeat this behavior on their systems.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.