The Corsair User Forums  

Go Back   The Corsair User Forums > Corsair Product Discussion > Keyboards and Mice

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
  #16  
Old 08-14-2019, 08:52 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 941
POST ID # = 1014689
Corsair Nick Reputation: 39
Default

Sounds like you've performed most of the basic troubleshooting steps for your mouse. If you haven't already done so, you will need to submit a ticket through our support site below:

https://support.corsair.com/

If you've already submitted a ticket, but haven't received a response yet, feel free to PM me with your ticket number and I'll follow up with our Technical Support team.
Reply With Quote


  #17  
Old 08-14-2019, 10:48 PM
Stud_Beefpiler Stud_Beefpiler is offline
Registered User
Stud_Beefpiler's PC Specs
 
Join Date: Aug 2019
Posts: 4
POST ID # = 1014695
Stud_Beefpiler Reputation: 10
Default

Thanks, Nick. I have submitted a ticket on 8/13. Based on the automated reply, I can expect a response of some sort within three to four business days.

Should I not receive any correspondence within that time frame, I will gladly take you up on your offer.

Thanks for following up.

</threadjack>

Last edited by Stud_Beefpiler; 08-14-2019 at 11:07 PM.
Reply With Quote


  #18  
Old 08-16-2019, 01:45 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 941
POST ID # = 1014863
Corsair Nick Reputation: 39
Default

Quote:
Originally Posted by Stud_Beefpiler View Post
Thanks, Nick. I have submitted a ticket on 8/13. Based on the automated reply, I can expect a response of some sort within three to four business days.

Should I not receive any correspondence within that time frame, I will gladly take you up on your offer.

Thanks for following up.

</threadjack>
No problem. Keep me posted on the status of your support ticket if you don't hear anything.
Reply With Quote


  #19  
Old 08-21-2019, 08:31 PM
DrkEagle DrkEagle is offline
Registered User
DrkEagle's PC Specs
 
Join Date: Apr 2016
Posts: 15
POST ID # = 1015360
DrkEagle Reputation: 10
Default

Same issue here, less than 1 year old.
Reply With Quote


  #20  
Old 09-06-2019, 01:25 AM
tdr144 tdr144 is offline
Registered User
 
Join Date: Sep 2019
Posts: 1
POST ID # = 1017065
tdr144 Reputation: 10
Default

hello,
i have similar problem, (m65 rgb, few months old), left click started to be bugged - i have to click really hard to system receive the click. In case of normal click - i can feel it, i can hear it but system does not know about it.

I tried new fw, new icue, i also tried on my laptop but its all the same. Any way how to fix it? Like older fw helped or something? thx for any advice.
Reply With Quote


  #21  
Old 09-22-2019, 12:22 PM
jmer88 jmer88 is offline
Registered User
 
Join Date: Sep 2019
Posts: 2
POST ID # = 1018978
jmer88 Reputation: 10
Default

Quote:
Originally Posted by tdr144 View Post
hello,
i have similar problem, (m65 rgb, few months old), left click started to be bugged - i have to click really hard to system receive the click. In case of normal click - i can feel it, i can hear it but system does not know about it.

I tried new fw, new icue, i also tried on my laptop but its all the same. Any way how to fix it? Like older fw helped or something? thx for any advice.
Same here but mine is less than a month old... yet outside Best Buy's return policy period....

Now I cannot guarantee left mouse clicks on a device I literally have had 28 days... I feel ripped off, honestly.
Reply With Quote


  #22  
Old 09-23-2019, 04:18 PM
Corsair Nick's Avatar
Corsair Nick Corsair Nick is offline
Corsair Employee
 
Join Date: Feb 2016
Posts: 941
POST ID # = 1019073
Corsair Nick Reputation: 39
Default

Quote:
Originally Posted by jmer88 View Post
Same here but mine is less than a month old... yet outside Best Buy's return policy period....

Now I cannot guarantee left mouse clicks on a device I literally have had 28 days... I feel ripped off, honestly.
You can actually have the unit replaced directly through Corsair. All of our mice and keyboards currently come with a 2-year warranty. Just submit a ticket through our support portal, and one of our Technical Support staff can help you with the replacement.

https://support.corsair/
Reply With Quote


  #23  
Old 10-06-2019, 09:50 AM
Burki Burki is offline
Registered User
 
Join Date: Oct 2019
Posts: 1
POST ID # = 1020430
Burki Reputation: 10
Default

I have the same problem. The left mouse button does not work properly. I can hear the click, but nothing happens. It only works if I press the mouse button very hard.

I have the problem since yesterday. I bought the M65 RGB Elite three months ago.

I kindly ask for support!
Reply With Quote


  #24  
Old 10-07-2019, 06:44 PM
oarsume oarsume is offline
Registered User
oarsume's PC Specs
 
Join Date: Oct 2019
Location: Australia - NSW
Posts: 1
POST ID # = 1020615
oarsume Reputation: 10
Default

Hi all. Registered just to tell you this.

Quick Fix. As i have one of these. And had the same issues.
Open iCUE - Settings - Click m65 - and 'clear on-board storage'
Cheers.
Let me know if this works for you?
Reply With Quote


  #25  
Old 10-21-2019, 04:57 PM
coachwill coachwill is offline
Registered User
coachwill's PC Specs
 
Join Date: Jul 2015
Posts: 3
POST ID # = 1021968
coachwill Reputation: 10
Default

I tried the file from customer support and it was the same firmware that I was already running through iCUE. So I went through their support steps and nothing was resolved. I tried the suggest that @oarsume posted and so far it seems to be working.

I'll keep you guys posted but I think this is a bigger issue than just firmware or mouse storage filling up.
Reply With Quote


  #26  
Old 10-30-2019, 05:08 AM
Phil1 Phil1 is offline
Registered User
 
Join Date: Oct 2019
Posts: 1
POST ID # = 1022695
Phil1 Reputation: 10
Default Fix that worked for me

Ok this fix will sound weird but fixed the left click issues for me completely.

I've replaced the M65 firmware multiple times from a support ticket, reset the mouse, changed between USB2 and 3 ports regularly. Some of these seemed to work for a few minutes and was back where I started. Gaming and doing graphic design was impossible. I did the fix below over a month ago now and it's been perfect.

Fix: It's not the electronics, it's that thumb panel (left hand side of the mouse)
If you wiggle it you will see there's some play in it. I found that panel was pushing down just enough to lift the sensor off the pad making the left click hit and miss unless you push down with some pressure.

I took a piece of sandpaper and sanded the bottom ledge of this panel (under the mouse) It's like a carbon material so sands very well, just don't get the black dust in your sensor cavity. This makes for better clearance and solved all clicking issues I had with the LMB.

Hope this helps someone with their problem.
Reply With Quote


  #27  
Old 11-06-2019, 06:54 PM
ttrt1 ttrt1 is offline
Registered User
 
Join Date: Aug 2018
Posts: 7
POST ID # = 1023270
ttrt1 Reputation: 10
Default

M65 Pro RGB, started acting up yesterday. Left clicking now requires a much firmer click on my part than it used to, otherwise it won't register or act strangely.
Example: dragging a window and it just releases it on its own part way through the operation, even though I didn't change my grip.

Very annoying, I paid more for a better mouse expecting that these sort of issues wouldn't be a problem. The mouse isn't that old, it shouldn't be doing this.

Corsair, please can you help? What should I do?

PS: As long as I'm already here, the scroll wheel started squeaking when used a couple of months back. I don't know why, it just started. I just thought that I'd bear it, since it's not a big issue, and I use headphones usually, but still, if I'm already going to ask about problems the mouse is having, I might as well bring it up too.

Last edited by ttrt1; 11-06-2019 at 07:09 PM.
Reply With Quote


  #28  
Old 11-07-2019, 11:14 PM
Tombs Tombs is offline
Registered User
 
Join Date: May 2016
Posts: 9
POST ID # = 1023356
Tombs Reputation: 10
Default

So, tried different firmware, different software, no software etc... Issue is hardware.

This is the 3rd M65 elite I've had in a year that has failed this way. No I don't have time to be without a mouse as you process an RMA. Just build a product that actually works.

I use a very light touch with my mouse, so it isn't from pressing the button too hard. This makes this specific issue doubly annoying as I have to teach myself to press harder than necessary to get an audible click.

Something tells me the interface of the mouse button that contacts the switch isn't wide enough to depress the whole bar of the omron switch. If I press the right side of the omron switch, I get a click without registering a button press. If I press the left side, it works correctly. It's an engineering fault with the interface of the mouse button, it needs to have a wider contact surface on the switch, which will help it last longer as the switch wears. I'm sure with some super glue and plastic shavings I could correct the issue but this is ridiculous. The contact surface on the underside of the mouse button that actually depresses the bar on the omron switch is about 2-3mm wide. If they'd make that contact surface at least as wide as the entire bar on the omron switch, this issue would go away.

Last edited by Tombs; 11-07-2019 at 11:20 PM.
Reply With Quote


Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.